码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3278 Catch That Cow(BFS)

时间:2019-03-11 00:44:09      阅读:175      评论:0      收藏:0      [点我收藏+]

标签:any   name   return   ==   ace   tran   lang   code   form   

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
#include <algorithm>
#include <stdio.h>
#include <queue>
#include <string.h>
#include <stdlib.h>
#include <iostream>
using namespace std;
const int N = 1000000;
bool book[1000010];
int n, k;

struct node{
    int num;
    int step;
};
bool check(int x){
    if(x<0 || x>N || book[x])
        return false;
    return true;
}
void BFS(){
    node q;
    
    q.num = n;
    q.step = 0;
    
    queue<node> qq;
    qq.push(q);
    
    book[n] = 1;
    
    while(!qq.empty()){
        node t = qq.front();
        qq.pop();
        
        if(t.num==k){
            cout<<t.step<<endl;
            return;
        }
    
        node tt = t;
        tt.num = t.num*2;
        if(check(tt.num)){
            book[tt.num] = true;
            tt.step = t.step+1;
            qq.push(tt);
        }
        tt.num = t.num-1;
        if(check(tt.num)){
            book[tt.num] = true;
            tt.step = t.step+1;
            qq.push(tt);
        }
        tt.num = t.num+1;
        if(check(tt.num)){
            book[tt.num] = true;
            tt.step = t.step+1;
            qq.push(tt);
        }    
    }
    printf("-1\n");
    return;
}

int main() {
    while(~scanf("%d%d",&n,&k)){
        memset(book,false,sizeof(book));
        BFS();    
    }
    
    return 0;
}

 

POJ 3278 Catch That Cow(BFS)

标签:any   name   return   ==   ace   tran   lang   code   form   

原文地址:https://www.cnblogs.com/0526yao/p/10508151.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!