码迷,mamicode.com
首页 > 其他好文 > 详细

数塔(杭电2084)

时间:2014-10-19 01:24:08      阅读:130      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   java   

数塔

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22445    Accepted Submission(s): 13522


Problem Description
在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?
bubuko.com,布布扣
已经告诉你了,这是个DP的题目,你能AC吗?
 

Input
输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。
 

Output
对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。
 

Sample Input
1 5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
 

Sample Output
30
#include<stdio.h>
int a[100][100];
int max(int x,int y)
{
    return x>y?x:y;
}
int main()
{
    int T,i,j,n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=i;j++)
            scanf("%d",&a[i][j]);
        }
        for(i=n-1;i>0;i--)//本题关键, 倒着求。 
        {
            for(j=1;j<=i;j++)
            a[i][j]=a[i][j]+max(a[i+1][j],a[i+1][j+1]);
        }
        printf("%d\n",a[1][1]);
    }
    return 0;
}


数塔(杭电2084)

标签:des   style   blog   http   color   io   os   ar   java   

原文地址:http://blog.csdn.net/hdd871532887/article/details/40251441

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!