码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3466 Proud Merchants(01背包)

时间:2014-10-19 09:04:07      阅读:178      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   java   

这道题目看出背包很容易,主要是处理背包的时候需要按照q-p排序然后进行背包。

这样保证了尽量多的利用空间。

Proud Merchants

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 2674    Accepted Submission(s): 1109


Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

 

Input
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

Output
For each test case, output one integer, indicating maximum value iSea could get.

 

Sample Input
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output
5 11
 

Author
iSea @ WHU
 

Source
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-10
///#define M 1000100
#define LL __int64
///#define LL long long
///#define INF 0x7ffffff
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
#define zero(x) ((fabs(x)<eps)?0:x)

///#define mod 10007

const int maxn = 5010;
using namespace std;


int dp[maxn];



struct node
{
    int p, q, v;
}f[510];

bool cmp(node a, node b)
{
    return a.q-a.p < b.q-b.p;
}

int main()
{
    int n, m;
    while(~scanf("%d %d",&n, &m))
    {
        for(int i = 1; i <= n; i++) scanf("%d %d %d",&f[i].p, &f[i].q, &f[i].v);
        for(int i = 0; i <= m; i++) dp[i] = 0;
        sort(f+1, f+n+1, cmp);
        for(int i = 1; i <= n; i++)
            for(int j = m; j >= f[i].q; j--) dp[j] = max(dp[j] , dp[j-f[i].p] + f[i].v);
        printf("%d\n",dp[m]);
    }
}

/*
3 10
3 6 10
3 8 4
2 10 7
*/


HDU 3466 Proud Merchants(01背包)

标签:des   style   blog   http   color   io   os   ar   java   

原文地址:http://blog.csdn.net/xu12110501127/article/details/40260001

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!