码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3071 Football (概率DP)

时间:2014-10-19 11:41:00      阅读:200      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   for   

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3162   Accepted: 1601

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrixP will satisfy the constraints that pij = 1.0 ? pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number ?1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins)  P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.



题意:2^n支足球队参加比赛,他们间互相比赛的胜率由矩阵给出,比赛的模式为如下

bubuko.com,布布扣   

即先是按顺序每2队比赛,然后剩下的每两队比赛,直到结束为止

思路:dp[i][j]表示第i场第j支队存在的概率

即其状态转移方程为:

  dp[i][j]= ∑dp[i-1][k]*p[j][k]*dp[i-1][j], k表示可能与j 比赛的队伍

然后就是求每次可能碰到的球队号码:从上图中发现第i场第j支队所

在编号t=j/(1<<(i-1)); 而其第i场可能遇到的对手的编号就是 t^1 , 

然后根据编号就可以知道原来的球队号码了。



<span style="font-size:18px;">#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1<<9;

double dp[10][maxn],p[maxn][maxn];
int n,len,a[10];

void input()
{
    len=1<<n;
    for(int i=0; i<len; i++)
        for(int j=0; j<len; j++)
            scanf("%lf",&p[i][j]);
}

void solve()
{
    memset(dp,0,sizeof(dp));
    for(int i=0; i<len; i++)  dp[0][i]=1.0;
    for(int i=1; i<=n; i++)
        for(int j=0; j<len; j++)
        {
            int t=j/a[i-1];
            t^=1;
            int l=a[i-1]*t,r=a[i-1]*(t+1)-1;
            for(int k=l; k<=r; k++)
                dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k];
        }
    double Max=0.0;
    int ans=-1;
    for(int i=0; i<len; i++)
    {
     //   cout<<dp[n][i]<<endl;
        if(Max<dp[n][i])
        {
            Max=dp[n][i];
            ans=i+1;
        }
    }
    printf("%d\n",ans);
}

int main()
{
    for(int i=0; i<10; i++)  a[i]=1<<i;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==-1)  break;
        input();
        solve();
    }
    return 0;
}</span><span style="font-size: 18pt;">
</span>



poj 3071 Football (概率DP)

标签:des   style   blog   http   color   io   os   ar   for   

原文地址:http://blog.csdn.net/u012596172/article/details/40260541

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!