码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1860 Currency Exchange(最短路)

时间:2014-10-19 14:21:07      阅读:245      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   io   os   ar   for   strong   

Currency Exchange
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 20482   Accepted: 7352

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

Source

Northeastern Europe 2001, Northern Subregion



       题意:有N种货币,货币之间通过汇率进行兑换,一个人持有一种货币,并且拥有一定数目的金额,问是否能通过货币之间的相互兑换实现他手中的货币的金额数增加,如果增加输出“YES” 反之输出“NO”。另外,货币之间的兑换是需要手续费的。例如,如果你想把100美元兑换成俄罗斯卢布,其中的汇率是29.75,而佣金是0.39,你会得到(100 - 0.39)*29.75=2963.3975俄罗斯卢布。明白这些就很好做了。
      第一行输入的数据:N种货币,M组数据,所持有的货币类别,所持有的货币的金额,
      第二行至第M+1行输入的数据:可以兑换的两种货币的种类x,y,后面的四个数分别代表把x兑换成y的汇率以及需要的手续费。和把y兑换成x的汇率以及所需要的手续费。
       可以看成是一个最短路问题:
贝尔曼福特算法代码:


#include<stdio.h>
#include<string.h>
#include<stdlib.h>

struct node
{
    int x,y;
    double a,b;
} q[1000100];

int n,m,s;
double k;
int t = 0;
double num[100010];

void add(int x,int y,double a,double b)
{
    q[t].x = x;
    q[t].y = y;
    q[t].a = a;
    q[t++].b = b;
}

int BF()
{
    for(int i=1; i<=n; i++)
    {
        num[i] = 0;
    }
    num[s] = k;
    for(int i=1; i<=n; i++)
    {
        int flag = 0;
        for(int j=0; j<t; j++)
        {
            if(num[q[j].y]<(num[q[j].x] - q[j].b) * q[j].a)
            {
                num[q[j].y] = (num[q[j].x] - q[j].b) * q[j].a;
                flag = 1;
                if((q[j].y == s && num[s]>k) || (q[i].x == s && num[s]>k))
                {
                    return 1;
                }
            }
        }
        if(flag == 0)
        {
            break;
        }
    }
    for(int j=0; j<t; j++)
    {
        if(num[q[j].y]<(num[q[j].x] - q[j].b) * q[j].a)
        {
            num[q[j].y] = (num[q[j].x] - q[j].b) * q[j].a;
            return 1;
        }
    }
    return 0;
}

int main()
{
    while(scanf("%d%d%d%lf",&n,&m,&s,&k)!=EOF)
    {
        double a1,b1,a2,b2;
        int x1,y1;
        t = 0;
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%lf%lf%lf%lf",&x1,&y1,&a1,&b1,&a2,&b2);
            add(x1,y1,a1,b1);
            add(y1,x1,a2,b2);
        }
        int kk = BF();
        if(kk == 1)
        {
            printf("YES\n");
        }
        else
        {
            printf("NO\n");
        }
    }
    return 0;
}


POJ 1860 Currency Exchange(最短路)

标签:des   style   http   color   io   os   ar   for   strong   

原文地址:http://blog.csdn.net/yeguxin/article/details/40261875

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!