标签:des style http color io os ar java for
Robberies
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12516 Accepted Submission(s): 4641
Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.
Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
Sample Output
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12516 Accepted Submission(s): 4641
Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.
Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
Sample Output
2 4 6
大致题意:主人公想从银行中获取最大利益,但是这是有一定风险的,那就是要避免被抓到。输入一个数T,表示有几组测试数据,接下来输入两个数n和m,分别表示被抓到的总概率概率和有几家银行。下面分别输入能从m家银行中获取的利益以及被抓到的概率是多少。求最后主人公能不超过n的情况下获取最多多少利益。
思路:这里首先要考虑精度问题。最重要的是找动态转移方程,可以将所用银行里的钱看作背包容量,每一家银行的钱看作重量,不被抓到的概率看作价值,则转移方程为:dp[ j ]=max( dp[ j ] , dp[ j - bag[ i ].v]*( 1- bag[ i ].p ) );
#include<iostream>
#include<algorithm>
using namespace std;
int dp[500010];
struct node
{
int money;
double p;
}bank[5555];
int main()
{
int T,n,i,j,sum;
double p;
scanf("%d",&T);
while(T--)//测试数据
{
sum=0;
scanf("%lf %d",&p,&n);//被抓到概率和几家银行
p=1-p;
for(i=0;i<n;i++)
{
scanf("%d %lf",&bank[i].money,&bank[i].p);//价值和概率
bank[i].p=1-bank[i].p;
sum+=bank[i].money;
}
double dp[10005]={1.0};
//memset(dp,0,sizeof(dp));
for(i=0;i<n;i++)
{
for(j=sum;j>=bank[i].money;j--)
{
if(dp[j-bank[i].money]*bank[i].p>dp[j])
dp[j]=dp[j-bank[i].money]*bank[i].p;
}
}
for(i=sum;i>=0;i--)
{
if(dp[i]-p>0.000000001)
{
printf("%d\n",i);
break;
}
}
}
return 0;
}
HDU 2955 Robberies (01背包)
标签:des style http color io os ar java for
原文地址:http://www.cnblogs.com/caterpillarofharvard/p/4035064.html