码迷,mamicode.com
首页 > 其他好文 > 详细

SDUT 1068-Number Steps(数学:直线)

时间:2014-10-19 21:29:03      阅读:183      评论:0      收藏:0      [点我收藏+]

标签:数学

Number Steps

Time Limit: 1000ms   Memory limit: 10000K  有疑问?点这里^_^

题目描述

Starting from point (0,0) on a plane, we have written all non-negative integers 0, 1, 2,... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued. 

bubuko.com,布布扣
 You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0...5000.

输入

The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.

输出

For each point in the input, write the number written at that point or write No Number if there is none.

示例输入

3
4 2
6 6
3 4

示例输出

6
12
No Number
就是按图中的规律给出两条直线。。我一开始居然没看出来是直线。。找规律打表敲了一大片结果wa了,后来发现就是判断点是否在直线上嘛 两条直线分别为y=x与y=x-2; 然后那个编号可以根据坐标x写出对应关系,很好写,都是等差数列,我是分奇偶讨论的。。
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <list>
#define ll long long
using namespace std;
const int INF=1<<27;
const int maxn=1010;
int main()
{
	int x,y,n;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d%d",&x,&y);
		if(x==y)
		{
			if(x%2)
				printf("%d\n",2*x-1);
			else
				printf("%d\n",2*x);
		}
		else if(y==x-2)
		{
			if(x%2)
				printf("%d\n",2*x-3);
			else
				printf("%d\n",2*x-2);
		}
		else
			puts("No Number");
	}
    return 0;
}



SDUT 1068-Number Steps(数学:直线)

标签:数学

原文地址:http://blog.csdn.net/qq_16255321/article/details/40268103

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!