码迷,mamicode.com
首页 > 其他好文 > 详细

poj1961--Period(KMP求最小循环节)

时间:2014-10-19 21:30:13      阅读:233      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   for   strong   sp   

Period
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 13511   Accepted: 6368

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

Source

Southeastern Europe 2004

和poj1961相同,http://blog.csdn.net/winddreams/article/details/40268107

不过是多加了一个对从头到每个字符的判断。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int next[1100000] ;
char s[1100000] ;
void getnext(int l)
{
    int j = 0 , k = -1 ;
    next[0] = -1 ;
    while( j < l )
    {
        if( k == -1 || s[j] == s[k] )
            next[++j] = ++k ;
        else
            k = next[k] ;
    }
}
int main()
{
    int n , i , num = 1 , l ;
    while(scanf("%d", &n) && n)
    {
        scanf("%s", s);
        getnext(n);
        printf("Test case #%d\n", num++);
        for(i = 1 ; i <= n ; i++)
        {
            l = i - next[i] ;
            if( i%l==0 && i/l != 1 )
                printf("%d %d\n", i, i/l);
        }
        printf("\n");
    }
    return 0;
}

poj1961--Period(KMP求最小循环节)

标签:des   style   blog   http   io   ar   for   strong   sp   

原文地址:http://blog.csdn.net/winddreams/article/details/40268155

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!