码迷,mamicode.com
首页 > 其他好文 > 详细

poj2481 cows(线段树单点更新)

时间:2014-10-19 23:18:34      阅读:250      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   for   

题目链接:

huangjing

题目意思:

给出n头牛的活动区间,比如区间[SI,sj]和[EI,EJ],如果前面一个区间完全包含另外一个区间那么说明前一头牛比后一头牛强壮。

思路:根据区间的右区间数来建树,然后用sum[]来维护牛在这些右区间的头数。首先要根据牛的区间顺序进行排序,当然从左像右排序,那么后面进行查询比自己强的牛的时候那么就只用找右区间比自己大的就可以了。那么如何更新呢??只需要单点查询,然后知道找到这头牛的右区间即可。。。那么这个问题就解决了。。。

题目:

Language:
Cows
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 13017   Accepted: 4327

Description

Farmer John‘s cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good. 

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John‘s N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E]. 

But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cowi is stronger than cowj

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases. 
For each test case, the first line is an integer N (1 <= N <= 105), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge. 

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0

Hint

Huge input and output,scanf and printf is recommended.

Source

POJ Contest,Author:Mathematica@ZSU

[Submit]   [Go Back]   [Status]   [Discuss]

bubuko.com,布布扣Home Page   bubuko.com,布布扣Go Back  bubuko.com,布布扣To top

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
#include<vector>
#include<cmath>
#include<string>
#include<queue>
#define eps 1e-9
#define ll long long
#define INF 0x3f3f3f3f
using namespace std;
const int maxn=100000+10;

int sum[maxn<<2],n,ans[maxn];

struct Node
{
    int st,en,id;
}node[maxn];

bool cmp(Node a,Node b)
{
    if(a.st==b.st)
        return a.en>b.en;
    return a.st<b.st;
}

void buildtree(int l,int r,int dex)
{
    sum[dex]=0;
    if(l==r)  return;
    int mid=(l+r)>>1;
    buildtree(l,mid,dex<<1);
    buildtree(mid+1,r,dex<<1|1);
}

int Query(int l,int r,int dex,int L,int R)
{
    if(L<=l&&R>=r)  return sum[dex];
    int mid=(l+r)>>1;
    if(L>mid) return Query(mid+1,r,dex<<1|1,L,R);
    else if(R<=mid) return  Query(l,mid,dex<<1,L,R);
    else return  Query(mid+1,r,dex<<1|1,L,R)+Query(l,mid,dex<<1,L,R);
}

void Update(int l,int r,int pos,int dex)
{
    sum[dex]++;
    if(l==r)  return;
    int mid=(l+r)>>1;
    if(pos<=mid)  Update(l,mid,pos,dex<<1);
    else Update(mid+1,r,pos,dex<<1|1);
}

int main()
{
    while(~scanf("%d",&n),n)
    {
        for(int i=1;i<=n;i++)
        {
             scanf("%d%d",&node[i].st,&node[i].en);
             node[i].id=i;
        }
        sort(node+1,node+1+n,cmp);
        buildtree(0,maxn,1);
        for(int i=1;i<=n;i++)
        {
            if(i!=1&&node[i].st==node[i-1].st&&node[i].en==node[i-1].en)//注意这个地方如果前后两个区间相等的话,因为前面一个更新的时候这个去年+1了,所以这里要判断一下
                ans[node[i].id]=ans[node[i-1].id];
            else
                ans[node[i].id]=Query(0,maxn,1,node[i].en,maxn);
            Update(0,maxn,node[i].en,1);
        }
        for(int i=1;i<n;i++)
            printf("%d ",ans[i]);
        printf("%d\n",ans[n]);
    }
    return 0;
}



poj2481 cows(线段树单点更新)

标签:des   style   blog   http   color   io   os   ar   for   

原文地址:http://blog.csdn.net/u014303647/article/details/40273511

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!