码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1005 I Think I Need a Houseboat

时间:2019-04-02 00:05:25      阅读:111      评论:0      收藏:0      [点我收藏+]

标签:ros   car   odi   order   ali   plm   arch   first   math.h   

POJ 1005 I Think I Need a Houseboat
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 114666   Accepted: 49465

Description

Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion. 

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.) 

技术图片

Input

The first line of input will be a positive integer indicating how many data sets will be included (N). Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.

Output

For each data set, a single line of output should appear. This line should take the form of: “Property N: This property will begin eroding in year Z.” Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out “END OF OUTPUT.”

Sample Input

2
1.0 1.0
25.0 0.0

Sample Output

Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.

Hint

1.No property will appear exactly on the semicircle boundary: it will either be inside or outside. 
2.This problem will be judged automatically. Your answer must match exactly, including the capitalization, punctuation, and white-space. This includes the periods at the ends of the lines. 
3.All locations are given in miles.

Source

 
解题思路:

Fred Mapper的家(X,Y)到侵蚀中心(0,0)的距离就是侵蚀半径R

那么Area = 1/2*pi*R 就是侵蚀到Fred Mapper家时的侵蚀面积

而侵蚀速度为每年50

那么侵蚀到Fred Mapper家需要 RestYear = Area/50 = pi*R/100 年

又要求从第一年开始计算,最后一年不够一年按一年计算,那么RestYear+1取整就可以了。 

根据题意建立数学模型如下:
      位于平面坐标第一二象限的一个半圆从原点(0,0)开始向(x,y)扩散,每次扩散50平方
      求第几次扩散会覆盖到(x,y), 其中y>0
 
      勾股定理半径 R^2 = (x-0)^2 + (y-0)^2
      半圆面积公式 Area = pi * R^2 / 2
      当 Area 是 50 整数倍时, 扩散次数 cnt = Area / 50
      当 Area 不是 50 整数倍时, 扩散次数 cnt = Area / 50 + 1   (亦即向上取整) 

#include <math.h>
#include <iostream>
using namespace std;
 
const static double PI = 3.141592654;   // 常量π
const static double HALF_PI = PI / 2;   // 半圆面积公式常量
const static double EACH_AREA = 50; // 每次扩散面积
 
int diffuse(double x, double y); 
int main(void) {
    int testCase = 0;   // 测试用例数
    cin >> testCase;
 
    for(int i = 1; i <= testCase; i++) {
        double x, y;
        cin >> x >> y;
        int cnt = diffuse(x, y);
        cout << "Property " << i << ": This property will begin eroding in year " << cnt << . << endl; 
    }
    cout << "END OF OUTPUT." << endl;
 
    //system("pause");
    return 0;
}
 
 
int diffuse(double x, double y) {
    double R2 = x * x + y * y;
    double Area = HALF_PI * R2;
    return (int) ceil(Area / EACH_AREA);    // 向上取整
} 

 

POJ 1005 I Think I Need a Houseboat

标签:ros   car   odi   order   ali   plm   arch   first   math.h   

原文地址:https://www.cnblogs.com/alan-blog-TsingHua/p/10640055.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!