码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1002 A+B for Polynomials

时间:2019-04-07 09:24:20      阅读:124      评论:0      收藏:0      [点我收藏+]

标签:bit   exp   should   space   include   items   wrap   lang   and   

1002 A+B for Polynomials (25 分)
 

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

N?1?? a?N?1???? N?2?? a?N?2???? ... N?K?? a?N?K????

where K is the number of nonzero terms in the polynomial, N?i?? and a?N?i???? (,) are the exponents and coefficients, respectively. It is given that 1,0.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;


int main(){
    map<int,double> mp;
    map<int,double>::iterator it;

    int n;
    cin >> n;
    while(n--){
        int x;double y;
        cin >> x >> y;
        mp[x]+=y;
    }
    cin >> n;
    while(n--){
        int x;double y;
        cin >> x >> y;
        mp[x]+=y;
    }
    vector<pair<int,double>> vec;
    for(it=mp.begin();it!=mp.end();it++){
//        cout << it->first << " " << it->second << " ";
        if(it->second != 0) {
            vec.push_back(make_pair(it->first, it->second));
        }
    }
    cout << vec.size();
    for(int i=vec.size()-1;i >= 0;i--){
//        cout << vec[i].first << " " << fixed << setprecision(1)<< vec[i].second;
        printf(" %d %.1f",vec[i].first,vec[i].second);

    }

    return 0;
}

——map  make_pair vector 之间的骚操作。。

 

PAT 1002 A+B for Polynomials

标签:bit   exp   should   space   include   items   wrap   lang   and   

原文地址:https://www.cnblogs.com/cunyusup/p/10663925.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!