码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2663 Tri Tiling

时间:2014-10-20 17:27:38      阅读:210      评论:0      收藏:0      [点我收藏+]

标签:poj   zoj   算法   

Tri Tiling
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7887   Accepted: 4134

Description

In how many ways can you tile a 3xn rectangle with 2x1 dominoes? 
Here is a sample tiling of a 3x12 rectangle. 
bubuko.com,布布扣

Input

Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 <= n <= 30.

Output

For each test case, output one integer number giving the number of possible tilings.

Sample Input

2
8
12
-1

Sample Output

3
153
2131

题解:a[i]=4*a[i-2]-a[i-4];  

#include <iostream>
using namespace std;
int main(){
	long long n,a[50];
	a[0]=1;a[2]=3; 
	for(int i=4;i<=30;i+=2)  
		a[i]=4*a[i-2]-a[i-4];  
	while (cin>>n&&n!=-1){
		if (n%2)
			cout<<0<<endl;
		else
			cout<<a[n]<<endl;
	}
	return 0;
}


poj 2663 Tri Tiling

标签:poj   zoj   算法   

原文地址:http://blog.csdn.net/codeforcer/article/details/40301431

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!