码迷,mamicode.com
首页 > 其他好文 > 详细

Binary Search

时间:2019-04-21 11:32:11      阅读:117      评论:0      收藏:0      [点我收藏+]

标签:str   include   sea   sample   ted   sam   ios   ons   pre   

Search II

You are given a sequence of n integers S and a sequence of different q integers T. Write a program which outputs C, the number of integers in T which are also in the set S.

Input

In the first line n is given. In the second line, n integers are given. In the third line q is given. Then, in the fourth line, q integers are given.

Output

Print C in a line.

Constraints

  • Elements in S is sorted in ascending order
  • n ≤ 100000
  • q ≤ 50000
  • 0 ≤ an element in S ≤ 109
  • 0 ≤ an element in T ≤ 109

Sample Input 1

5
1 2 3 4 5
3
3 4 1

Sample Output 1

3

Sample Input 2

3
1 2 3
1
5

Sample Output 2

0

Sample Input 3

5
1 1 2 2 3
2
1 2

Sample Output 3

2

#include <iostream>
using namespace std;
int a[100010], b[50010];
int n, q;

int binarySearch(int c)
{
	int mid;
	int left = 0, right = n - 1;
	while(left <= right)
	{
		mid = left + (right - left) / 2;
		if(a[mid] == c)	
		{
			return 1;
		}
		else if(c < a[mid]) 
		{
			right = mid - 1;
		}
		else 
		{
			left = mid + 1;
		}
	}
	
	return 0;	
}

int main()
{
	int sum = 0;
	cin >> n;
	for(int i = 0; i < n; ++ i)
		cin >> a[i];
	
	cin >> q;
	for(int i = 0; i < q; ++ i)
	{
		cin >> b[i];
		if(binarySearch(b[i]))	sum ++;
	}
	
	cout << sum << endl;
	
	return 0;
}

  

Binary Search

标签:str   include   sea   sample   ted   sam   ios   ons   pre   

原文地址:https://www.cnblogs.com/mjn1/p/10744257.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!