码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4791 Alice's Print Service 水二分

时间:2014-10-20 19:36:21      阅读:178      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   java   


Alice‘s Print Service

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1084    Accepted Submission(s): 240


Problem Description
Alice is providing print service, while the pricing doesn‘t seem to be reasonable, so people using her print service found some tricks to save money.
For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It‘s easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.
Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.
 

Input
The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.
Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 105 ). The second line contains 2n integers s1, p1 , s2, p2 , ..., sn, pn (0=s1 < s2 < ... < sn ≤ 109 , 109 ≥ p1 ≥ p2 ≥ ... ≥ pn ≥ 0).. The price when printing no less than si but less than si+1 pages is pi cents per page (for i=1..n-1). The price when printing no less than sn pages is pn cents per page. The third line containing m integers q1 .. qm (0 ≤ qi ≤ 109 ) are the queries.
 

Output
For each query qi, you should output the minimum amount of money (in cents) to pay if you want to print qi pages, one output in one line.
 

Sample Input
1 2 3 0 20 100 10 0 99 100
 

Sample Output
0 1000 1000
 

Source
 

先逆序求出最小,然后二分查找要求的位置。
//484MS	2556K
#include<stdio.h>
#include<algorithm>
#define inf 1e13
using namespace std;
__int64 s[100007];
__int64 x[100007],y[100007];
int main()
{
    //freopen("in.txt","r",stdin);
    int t;
    scanf("%d",&t);
    while(t--)
    {
        __int64 mi;
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            scanf("%I64d %I64d",&x[i],&y[i]);
        for(int i=1;i<=n;i++)s[i]=x[i]*y[i];
        s[n+1]=inf;
        mi=s[n+1];
        for(int i=n;i>=1;i--)
        {
            mi=min(s[i],mi);
            s[i]=mi;
        }
        while(m--)
        {
            __int64 q,minn;
            scanf("%I64d",&q);
            int pos=lower_bound(x+1,x+n+1,q)-x;//在first和last中的前闭后开区间进行二分查找,返回大于或等于val的第一个元素位置。如果所有元素都小于val,则返回last的位置
            minn=min(q*y[pos],s[pos+1]);
            printf("%I64d\n",minn);
        }
    }
    return 0;
}


HDU 4791 Alice's Print Service 水二分

标签:des   style   blog   http   color   io   os   ar   java   

原文地址:http://blog.csdn.net/crescent__moon/article/details/40303767

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!