码迷,mamicode.com
首页 > 其他好文 > 详细

hdu_1009 贪心

时间:2019-04-30 16:53:08      阅读:96      评论:0      收藏:0      [点我收藏+]

标签:javabean   ati   ret   contain   eal   script   NPU   otto   case   

FatMouse‘ Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 105467    Accepted Submission(s): 36835


 

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1‘s. All integers are not greater than 1000.
 
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
 
Sample Output
13.333
31.500

经典贪心,老鼠要换取到最多的JavaBean,按照每个房间的j和f,算出比率,当然是j/f越大越好,按照比率排一下序。
#include <iostream>
#include <stdio.h>
#include <algorithm>

using namespace std;

struct dat
{
    int j;
    int f;
    double sc;
} data[1000];

bool cmp(dat a, dat b)
{
    return a.sc>b.sc;
}

int main()
{
    int m,n;
    double ans;
    while(scanf("%d%d",&m,&n) && m!=-1 && n!=-1)
    {
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&data[i].j, &data[i].f);
            data[i].sc = (double)data[i].j/(double)data[i].f;
        }

        sort(data, data+n, cmp);

        ans = 0;
        for(int i=0; i<n; i++)
        {
            if(data[i].f<=m)
            {
                ans+=data[i].j;
                m-=data[i].f;
            }
            else
            {
                ans+=data[i].sc*(double)m;
                break;
            }

        }
        printf("%.3f\n", ans);
    }

    return 0;
}

 

hdu_1009 贪心

标签:javabean   ati   ret   contain   eal   script   NPU   otto   case   

原文地址:https://www.cnblogs.com/Dawn-bin/p/10796769.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!