码迷,mamicode.com
首页 > 其他好文 > 详细

水题(用map)--hdu1247

时间:2019-05-01 18:29:46      阅读:161      评论:0      收藏:0      [点我收藏+]

标签:ace   txt   ret   alpha   algo   cout   nat   open   back   

hdu1247
Hat’s Words
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20276 Accepted Submission(s): 7108

Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.

Sample Input
a
ahat
hat
hatword
hziee
word

Sample Output
ahat
hatword

Author
戴帽子的

代码

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <sstream>
#include <algorithm>
#include <set>
#include <map>
#include <vector>
#include <queue>
#include <iomanip>
#include <stack>

using namespace std;

typedef long long LL;
const int INF = 0x3f3f3f3f;
const int N = 5e4 + 5;
const int MOD = 1e9 + 9;

#define lson l, m, rt << 14
#define rson m + 1, r, rt << 1 | 1
#define F(i, l, r) for(int i = l;i <= (r);++i)
#define RF(i, l, r) for(int i = l;i >= (r);--i)

vector<string> v;
map<string, int> m;
int main()
{
    //freopen("in.txt", "r", stdin);
    string s;
    while(cin >> s) {v.push_back(s);m[s]++;}

    int len = v.size();
    F(i, 0, len - 1)
    {
        int t = v[i].size();
        F(j, 1, t - 2)
            if(m[v[i].substr(j)] && m[v[i].substr(0, j)])
            {cout << v[i] << endl;break;}
    }
    return 0;
}

水题(用map)--hdu1247

标签:ace   txt   ret   alpha   algo   cout   nat   open   back   

原文地址:https://www.cnblogs.com/shuizhidao/p/10800330.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!