码迷,mamicode.com
首页 > 其他好文 > 详细

【题解】排队接水

时间:2019-05-02 23:33:54      阅读:288      评论:0      收藏:0      [点我收藏+]

标签:sort   color   style   using   include   eve   cbe   int   pen   

题目描述

  有N个人排队到M个水龙头去打水,他们装满水桶的时间T1,T2,...,Tn为整数且各不相等,应如何安排他们的打水顺序才能使他们花费的总时间最少?

 

输入格式

  第一行,两个整数n和m,n表示人的个数,m表示水龙头的个数;

  第二行,n个数,分别表示n个人装水的时间;

 

输出格式

  一行,一个整数,表示总花费的最少时间。

 

输入样例

6 2

5 4 6 2 1 7

 

输出样例

40

 

题解

  我们开一个数组维护$m$个水龙头当前的打水等待时间,每次选时间最小的打水即可。

技术图片
#include <iostream>
#include <algorithm>

using namespace std;

int n, m;
int a[1005];
int s[1005];
int ans;

int main()
{
    cin >> n >> m;
    for(register int i = 1; i <= n; ++i)
    {
        cin >> a[i];
    }
    sort(a + 1, a + n + 1);
    s[0] = 214743647;
    int pos;
    for(register int i = 1; i <= n; ++i)
    {
        pos = 0;
        for(register int j = 1; j <= m; ++j)
        {
            if(s[pos] > s[j]) pos = j;
        }
        s[pos] += a[i];
        ans += s[pos];
    }
    cout << ans;
    return 0;
}
参考程序

 

【题解】排队接水

标签:sort   color   style   using   include   eve   cbe   int   pen   

原文地址:https://www.cnblogs.com/kcn999/p/10803525.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!