码迷,mamicode.com
首页 > 其他好文 > 详细

upc组队赛14 Floating-Point Hazard【求导】

时间:2019-05-03 21:10:56      阅读:142      评论:0      收藏:0      [点我收藏+]

标签:note   try   scl   log   ack   mina   orm   after   +=   

Floating-Point Hazard

题目描述

Given the value of low, high you will have to find the value of the following expression:
\(\sum_{i=low}^{high}(\sqrt[3]{(i+10^{-15})}-\sqrt[3]i)\)
If you try to find the value of the above expression in a straightforward way, the answer may be incorrect due to precision error.

输入

The input file contains at most 2000 lines of inputs. Each line contains two integers which denote the value of low, high (1 ≤ low ≤ high ≤ 2000000000 and high-low ≤ 10000). Input is terminated by a line containing two zeroes. This line should not be processed.

输出

For each line of input produce one line of output. This line should contain the value of the expression above in exponential format. The mantissa part should have one digit before the decimal point and be rounded to five digits after the decimal point. To be more specific the output should be of the form d.dddddE-ddd, here d means a decimal digit and E means power of 10. Look at the output for sample input for details. Your output should follow the same pattern as shown below.

样例输入

1 100
10000 20000
0 0

样例输出

3.83346E-015
5.60041E-015

题解

很有意思的求导公式,学到了
https://blog.csdn.net/wangws_sb/article/details/89676999

代码

#include<bits/stdc++.h>
using namespace std;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define scac(x) scanf("%c",&x)
#define sca(x) scanf("%d",&x)
#define sca2(x,y) scanf("%d%d",&x,&y)
#define sca3(x,y,z) scanf("%d%d%d",&x,&y,&z)
#define scl(x) scanf("%lld",&x)
#define scl2(x,y) scanf("%lld%lld",&x,&y)
#define scl3(x,y,z) scanf("%lld%lld%lld",&x,&y,&z)
#define pri(x) printf("%d\n",x)
#define pri2(x,y) printf("%d %d\n",x,y)
#define pri3(x,y,z) printf("%d %d %d\n",x,y,z)
#define prl(x) printf("%lld\n",x)
#define prl2(x,y) printf("%lld %lld\n",x,y)
#define prl3(x,y,z) printf("%lld %lld %lld\n",x,y,z)
#define ll long long
#define LL long long
#define pb push_back
#define mp make_pair
#define P pair<int,int>
#define PLL pair<ll,ll>
#define PI acos(1.0)
#define eps 1e-6
#define inf 1e17
#define INF 0x3f3f3f3f
#define N 5005
const int maxn = 2000005;
double n,m;
double ans;
int cnt ;
int main()
{
  while(scanf("%lf %lf",&n,&m)&&n&&m)
  {
    ans = 0;
    rep(i,n,m+1)
      ans+= 1.0/3.0*pow(double(i),-2.0/3.0);
    cnt = 0;
    while(ans<1)
    {
      ans*=10.0;
      cnt--;
    }
    while(ans>=10)
    {
      ans/=10.0;
      cnt++;
    }
    printf("%.5lfE-%03d\n",ans,15-cnt);
  }
}

upc组队赛14 Floating-Point Hazard【求导】

标签:note   try   scl   log   ack   mina   orm   after   +=   

原文地址:https://www.cnblogs.com/llke/p/10806591.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!