码迷,mamicode.com
首页 > 其他好文 > 详细

LightOJ1284 Lights inside 3D Grid (概率DP)

时间:2019-05-07 22:51:07      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:src   input   span   task   std   less   using   eve   integer   

You are given a 3D grid, which has dimensions XY and Z. Each of the X x Y x Z cells contains a light. Initially all lights are off. You will have K turns. In each of the K turns,

  1. You select a cell A randomly from the grid,
  2. You select a cell B randomly from the grid and
  3. Toggle the states of all the bulbs bounded by cell A and cell B, i.e. make all the ON lights OFF and make all the OFF lights ON which are bounded by A and B. To be clear, consider cell A is (x1, y1, z1) and cell B is (x2, y2, z2). Then you have to toggle all the bulbs in grid cell (x, y, z) where min(x1, x2) ≤ x ≤ max(x1, x2)min(y1, y2) ≤ y ≤ max(y1, y2) and min(z1, z2) ≤ z ≤ max(z1, z2).

Your task is to find the expected number of lights to be ON after K turns.

Input

Input starts with an integer T (≤ 50), denoting the number of test cases.

Each case starts with a line containing four integers X, Y, Z (1 ≤ X, Y, Z ≤ 100) and K (0 ≤ K ≤ 10000).

Output

For each case, print the case number and the expected number of lights that are ON after K turns. Errors less than 10-6will be ignored.

Sample Input

5

1 2 3 5

1 1 1 1

1 2 3 0

2 3 4 1

2 3 4 2

Sample Output

Case 1: 2.9998713992

Case 2: 1

Case 3: 0

Case 4: 6.375

Case 5: 9.09765625

题解:

技术图片

技术图片

 

参考代码:

技术图片
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int T,X,Y,Z,K;
double ans;

double calc(int x,int m)
{
    return 1.0-1.0*((m-x)*(m-x)+(x-1)*(x-1))/(m*m);
}

int main()
{
    scanf("%d",&T);
    for(int cas=1;cas<=T;++cas)
    {
        ans=0;
        scanf("%d%d%d%d",&X,&Y,&Z,&K);
        for(int i=1;i<=X;++i)
            for(int j=1;j<=Y;++j)
                for(int k=1;k<=Z;++k)
                {
                    double p=calc(i,X)*calc(j,Y)*calc(k,Z);
                    ans+=0.5-0.5*pow(1.0-2*p,K);
                }
        printf("Case %d: %.8lf\n",cas,ans);
    } 
    
    return 0; 
}
View Code

 

LightOJ1284 Lights inside 3D Grid (概率DP)

标签:src   input   span   task   std   less   using   eve   integer   

原文地址:https://www.cnblogs.com/songorz/p/10828658.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!