码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2533:Longest Ordered Subsequence

时间:2019-05-09 22:17:43      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:sdn   add   input   color   long   ace   output   must   release   

Longest Ordered Subsequence


Longest Ordered Subsequence
Time Limit:?2000MS ? Memory Limit:?65536K
Total Submissions:?31680 ? Accepted:?13848

Description

A numeric sequence of?ai?is ordered if?a1?<?a2?< ... <?aN. Let the subsequence of the given numeric sequence (a1,?a2, ...,?aN) be any sequence (ai1,?ai2, ...,?aiK), where 1 <=?i1?<?i2?< ... <?iK?<=?N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4


这是一道动归题。

n=3


1 7 3 5 9 4 8

dp[]=0;

1 ap[1]=0
7 dp[2]=1
3 dp[3]=1
5 d[4]=2
9 d[5]=3
4 d[6]=2
8 d[7]=3

最后找出最大值然后加一;

详细实现例如以下:



#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

const int M = 1000+5;
int sequence[M];    //输入的数据
int dp[M];          

int main()
{
    int n;
    while(scanf("%d", &n)!=EOF)
    {
        for(int i=1; i<=n; i++)
            scanf("%d",  &sequence[i]);
        memset(dp, 0, sizeof(dp));          //初始化为0
        for(int i=1; i<=n; i++)
            for(int j=1; j<i; j++)
            {
                if(sequence[i]>sequence[j])
                    dp[i] = max(dp[i], dp[j] + 1);    //动归方程
            }
        int ans=0;
        for(int i=1; i<=n; i++)
            ans = max(ans, dp[i]);
        printf("%d\n", ans+1);
    }
    return 0;
}


POJ2533:Longest Ordered Subsequence

标签:sdn   add   input   color   long   ace   output   must   release   

原文地址:https://www.cnblogs.com/mqxnongmin/p/10841138.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
分享档案
周排行
mamicode.com排行更多图片
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!