码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj - 1506 直方图中最大的矩形

时间:2019-05-12 19:49:00      阅读:91      评论:0      收藏:0      [点我收藏+]

标签:最大的   bsp   ecif   pre   i++   ase   rip   tle   alc   

Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:
技术图片
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
 
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 
Sample Input
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
 
Sample Output
8 4000
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

int a[100005];
int l[100005],r[100005];
int main()
{
    int n;
    
    while(scanf("%d",&n) && n != 0)
    {
        long long ans=0;
        memset(a,0,sizeof(a));
        for(int i = 0;i<n;i++)
        {
            scanf("%d",&a[i]);
            l[i] = r[i] = i;
            while(l[i] > 0 && a[l[i]-1] >= a[i])
            {
                l[i] = l[l[i]-1];
            }
        }
        for(int i = n-1;i>=0;i--)
        {
            while(r[i]<n-1 && a[r[i]+1] >= a[i])
            {
                r[i] = r[r[i]+1];
            }
        }
        for(int i = 0;i<n;i++)
        {
            long long  s = (long long)a[i]*(r[i]-l[i]+1);
            if(s>ans)
            {
                ans = s;
            }
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

Largest Rectangle in a Histogram【暑期培训Q题】【DP】【递归】

hdoj - 1506 直方图中最大的矩形

标签:最大的   bsp   ecif   pre   i++   ase   rip   tle   alc   

原文地址:https://www.cnblogs.com/hdyss/p/10853303.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!