码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3080 Blue Jeans (KMP)

时间:2019-05-12 19:55:16      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:strong   inpu   题意   tmp   最长公共子序列   ace   ted   http   bee   

链接:http://poj.org/problem?id=3080

 


 

 

题目:

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. 

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT


题意:
给出几个长度为60的字符串 求他们的最长公共子序列

思路:
因为长度很短 可以用暴力来做
把第一个字符串当作T串 拆分出所有的子串 然后和下面所有的字符串进行匹配

代码:
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <algorithm>

using namespace std;
const int maxn=70;
int t,n,nx[maxn];
string s[maxn];


void getnx(string tmp,int len){
    int j=0,k=-1;
    nx[0]=-1;
    while(j<len){
        if(k==-1 || tmp[j]==tmp[k]) nx[++j]=++k;
        k=nx[k];
    }
}

int KMP_Index(string S,string T){
    int i=0,j=0;
    int slen=S.size(),tlen=T.size();
    while(i<slen && j<tlen){
        if(j==-1 || S[i]==T[j]) i++,j++;
        else j=nx[j];
    }
    if(j==tlen) return 1;
    else return 0;
}

int main(){
 //   freopen("1.in","r",stdin);
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i=1;i<=n;i++) cin>>s[i];
        string ans=" ";
        for(int i=1;i<=s[1].size();i++){
            for(int j=0;j<=s[1].size()-i;j++){
                memset(nx,0,sizeof(nx));
                string tmp=s[1].substr(j,i);
                getnx(tmp,tmp.size());
                int flag=0;
                for(int k=2;k<=n;k++){
                    if(KMP_Index(s[k],tmp)==0) flag=1;
                }
                if(flag==0){
                    if(ans.size()<tmp.size()) ans=tmp;
                    else if(ans.size()==tmp.size()) ans=min(ans,tmp);
                }
            }
        }
        if(ans.size()<3) printf("no significant commonalities\n");
        else cout<<ans<<endl;
    }
    return 0;
}

 

POJ 3080 Blue Jeans (KMP)

标签:strong   inpu   题意   tmp   最长公共子序列   ace   ted   http   bee   

原文地址:https://www.cnblogs.com/whdsunny/p/10853252.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!