码迷,mamicode.com
首页 > 其他好文 > 详细

Humble Numbers

时间:2014-05-15 01:36:22      阅读:230      评论:0      收藏:0      [点我收藏+]

标签:humble numbers   穷举   ugly number相同思路   

                                                                              Humble Numbers

题目描述
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 


Write a program to find and print the nth element in this sequence
输入
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
输出
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
样例输入
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0
样例输出
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.

The 5842nd humble number is 2000000000.


#include<iostream>
using namespace std;
long int x[5900];
int num2=0,num3=0,num5=0,num7=0;
void t()
{
    x[0]=1;
    for(int i=1;i<5900;i++)
    {
      int min=x[num2]*2,b=x[num3]*3,c=x[num5]*5,d=x[num7]*7;
        if(min>b)
        {
            min=b;
        }
        if(min>c)
        {
            min=c;
        }
        if(min>d)
        {
            min=d;
        }
        x[i]=min;
        if(x[i]==x[num2]*2)
            num2++;
        if(x[i]==x[num3]*3)
            num3++;
        if(x[i]==x[num5]*5)
            num5++;
        if(x[i]==x[num7]*7)
            num7++;
        }
}
int main()
{
    int n;
    t();
    while(cin>>n&&n!=0)
    {
        if(n%10==1&&n!=11)
        cout<<"The"<<" "<<n<<"st"<<" "<<"humble number is "<<x[n-1]<<"."<<endl;
        else if(n%10==2&&n!=12)
            cout<<"The"<<" "<<n<<"nd"<<" "<<"humble number is "<<x[n-1]<<"."<<endl;
        else if(n%10==3&&n!=13)
            cout<<"The"<<" "<<n<<"rd"<<" "<<"humble number is "<<x[n-1]<<"."<<endl;
        else cout<<"The"<<" "<<n<<"th"<<" "<<"humble number is "<<x[n-1]<<"."<<endl;
 
    }
    return 0;
}
此题思路同ugly number 一样,也就是要缩小穷举范围,

一直因子只能是2,3,5,7,所以分别用四个量来表示,通过将最小值放入数组中构造成功

另外需要考虑输出形式,在11,12,13处分别有小陷阱需注意

Humble Numbers,布布扣,bubuko.com

Humble Numbers

标签:humble numbers   穷举   ugly number相同思路   

原文地址:http://blog.csdn.net/u013240812/article/details/25830615

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!