码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1711 Number Sequence(kmp)

时间:2014-10-21 21:38:27      阅读:258      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   io   os   ar   for   sp   div   

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
6 -1
 

Source
 

Recommend

还是kmp,就是把字符变成整型数组了,还是模板


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<vector>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)
using namespace std;
#define N  1000005

int n,m;
int a[N],b[N];
int next[N];

void getfail(int *b)
{
	int i,j;
	next[0]=-1;
	j=-1;
	i=0;

	while(i<m)
		if(j==-1||b[i]==b[j])
	{
		i++;
		j++;
		next[i]=j;
	}
     else
		j=next[j];
}

int kmp(int *a,int *b)
{
	int i,j;
	i=j=0;
	while(i<n)
	{
		if(j==-1||a[i]==b[j])
		{
			i++;
			j++;
		}
		else
			j=next[j];

		if(j==m)
			return i-j+1;
	}
   return -1;
}

int main()
{
	int t,i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);

		for(i=0;i<n;i++)
			scanf("%d",&a[i]);

		for(i=0;i<m;i++)
			scanf("%d",&b[i]);

		getfail(b);

		printf("%d\n",kmp(a,b));
	}
   return 0;
}






HDU 1711 Number Sequence(kmp)

标签:des   style   http   io   os   ar   for   sp   div   

原文地址:http://blog.csdn.net/u014737310/article/details/40350445

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!