码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1753 Flip Game

时间:2014-10-21 23:18:43      阅读:314      评论:0      收藏:0      [点我收藏+]

标签:bfs   反转   棋盘问题   

Flip Game
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 31424   Accepted: 13656

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it‘s black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

bubuko.com,布布扣Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it‘s impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

稀里哗啦写了一大堆,最后发现就是十六步枚举,一维二维就无所谓了!!!

#include<iostream>
using namespace std;
int chess[17];
int k;
int judge()
{
	int i;
	for(i=2;i<=16;i++)
		if(chess[i]!=chess[i-1]) return 0;
		return 1;
}
void convert(int i)
{
	chess[i]^=1;
	if(i%4!=1) chess[i-1]^=1;
	if(i%4!=0) chess[i+1]^=1;
	if(i>4) chess[i-4]^=1;
	if(i<13) chess[i+4]^=1;
}
void bfs(int j,int now,int total)//现在到第j个棋子了,翻转了now次,总共翻转了total次。
{
	int i;
	if(now==total)
	{
		k=judge();
		return;
	}
	for(i=j+1;i<=16;i++)
	{
		convert(i);
		bfs(i,now+1,total);
		if(k) return;
		convert(i);//还原。
	}
}
int main()
{
	int i;
	char ch;
	for(i=1;i<=16;i++)//输入,用0代替w,用1代替b。
	{
		cin>>ch;
		if(ch=='w') chess[i]=0;
		else chess[i]=1;
	}
	k=judge();
	if(k) cout<<0<<endl;
	else
	{
		for(i=1;i<=16;i++)//最多翻转16次,枚举。
		{
			k=0;
			bfs(0,0,i);
			if(k) break;
		}
		if(k) cout<<i<<endl;
		else cout<<"Impossible\n";
	}
	return 0;
}




POJ 1753 Flip Game

标签:bfs   反转   棋盘问题   

原文地址:http://blog.csdn.net/u014492609/article/details/40352317

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!