码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1163 The Triangle

时间:2019-06-01 19:44:46      阅读:89      评论:0      收藏:0      [点我收藏+]

标签:read   解题思路   cin   std   top   最大和   完成   cout   where   

Time Limit: 1000MS              Memory Limit: 10000K
Total Submissions: 60993        Accepted: 36560

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

解题思路:

直接读入三角形,从最后一行开始自底向上计算最大和,直至计算完成,输出顶端最大和即可。算是动归非常基础的入门题了。

AC代码:
#include<iostream>
#include<algorithm>
using namespace std;

int V[101][101];

int main()
{
    int n;
    cin >> n;
    for(int i = 0; i < n; i++)
    {
        for (int j = 0; j < (i+1); j++)
        {
            cin >> V[i][j];
        }
    }
    for (int i = n - 1; i > 0; i--)
    {
        for (int k = 0; k < i; k++) //自底向上更新
        {
            V[i - 1][k] += max(V[i][k], V[i][k + 1]);
        }
    }
    cout << V[0][0];
    return 0;
}

 

 
 

POJ 1163 The Triangle

标签:read   解题思路   cin   std   top   最大和   完成   cout   where   

原文地址:https://www.cnblogs.com/yun-an/p/10960512.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!