码迷,mamicode.com
首页 > 其他好文 > 详细

Poj 2391 Ombrophobic Bovines 网络流 拆点

时间:2019-06-07 23:16:39      阅读:200      评论:0      收藏:0      [点我收藏+]

标签:else   create   join   cte   cap   答案   sum   str   must   

Poj 2391 Ombrophobic Bovines 网络流 拆点

FJ's cows really hate getting wet so much that the mere thought of getting caught in the rain makes them shake in their hooves. They have decided to put a rain siren on the farm to let them know when rain is approaching. They intend to create a rain evacuation plan so that all the cows can get to shelter before the rain begins. Weather forecasting is not always correct, though. In order to minimize false alarms, they want to sound the siren as late as possible while still giving enough time for all the cows to get to some shelter.

The farm has F (1 <= F <= 200) fields on which the cows graze. A set of P (1 <= P <= 1500) paths connects them. The paths are wide, so that any number of cows can traverse a path in either direction.

Some of the farm's fields have rain shelters under which the cows can shield themselves. These shelters are of limited size, so a single shelter might not be able to hold all the cows. Fields are small compared to the paths and require no time for cows to traverse.

Compute the minimum amount of time before rain starts that the siren must be sounded so that every cow can get to some shelter. 

Input

* Line 1: Two space-separated integers: F and P

* Lines 2..F+1: Two space-separated integers that describe a field. The first integer (range: 0..1000) is the number of cows in that field. The second integer (range: 0..1000) is the number of cows the shelter in that field can hold. Line i+1 describes field i.

* Lines F+2..F+P+1: Three space-separated integers that describe a path. The first and second integers (both range 1..F) tell the fields connected by the path. The third integer (range: 1..1,000,000,000) is how long any cow takes to traverse it. 

Output
* Line 1: The minimum amount of time required for all cows to get under a shelter, presuming they plan their routes optimally. If it not possible for the all the cows to get under a shelter, output "-1".
Sample Input

3 4
7 2
0 4
2 6
1 2 40
3 2 70
2 3 90
1 3 120

Sample Output

110

Hint
OUTPUT DETAILS:

In 110 time units, two cows from field 1 can get under the shelter in that field, four cows from field 1 can get under the shelter in field 2, and one cow can get to field 3 and join the cows from that field under the shelter in field 3. Although there are other plans that will get all the cows under a shelter, none will do it in fewer than 110 time units. 

分析:

又是经典的floyd+二分答案 但是这里要注意建图时对每一个草地要进行拆点,即每个点拆成两个点x和x‘,源点向x连边,权值为初始的牛的数量;x‘向汇点连边,权值为可以容纳的牛的数量;x向x‘连边,权值为INF。

然后枚举任意两点i和j,如果i和j之间的最短距离d[i][j]<=mid,则建边i->j‘,权值为INF。

此时计算最大流,就是在限定mid时间内可以移动的最多的牛的数量,如果等于牛的总数则说明可行,否则不可行。继续二分。

代码如下:

#include<cstdio>
#include<vector>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int maxn=500+10;
const int INF1 = 1e9;
const ll INF2 = 1LL<<60;
int f,p,total = 0;
int a[maxn],b[maxn];
ll d[maxn][maxn],l = 0,r,mid;
struct Edge
{
    int from,to,cap,flow;
    Edge(){}
    Edge(int f,int t,int c,int fl):from(f),to(t),cap(c),flow(fl){}
};
struct Dinic
{
    int n,m,s,t;
    vector<Edge> edges;
    vector<int> G[maxn];
    int d[maxn];
    int cur[maxn];
    bool vis[maxn];
 
    void init(int n,int s,int t)
    {
        this->n=n, this->s=s, this->t=t;
        edges.clear();
        for(int i=0;i<n;i++) G[i].clear();
    }
    void AddEdge(int from,int to,int cap)
    {
        edges.push_back( Edge(from,to,cap,0) );
        edges.push_back( Edge(to,from,0,0) );
        m=edges.size();
        G[from].push_back(m-2);
        G[to].push_back(m-1);
    }
    bool BFS()
    {
        queue<int> Q;
        memset(vis,0,sizeof(vis));
        vis[s]=true;
        d[s]=0;
        Q.push(s);
        while(!Q.empty())
        {
            int x=Q.front(); Q.pop();
            for(int i=0;i<G[x].size();i++)
            {
                Edge e=edges[G[x][i]];
                if(!vis[e.to] && e.cap>e.flow)
                {
                    vis[e.to]=true;
                    d[e.to] = d[x]+1;
                    Q.push(e.to);
                }
            }
        }
        return vis[t];
    }
 
    int DFS(int x,int a)
    {
        if(x==t || a==0) return a;
        int flow=0,f;
 
        for(int& i=cur[x];i<G[x].size();++i)
        {
            Edge& e=edges[G[x][i]];
            if(d[e.to]==d[x]+1 && (f=DFS(e.to, min(a,e.cap-e.flow) ) )>0 )
            {
                e.flow+=f;
                edges[G[x][i]^1].flow-=f;
                flow+=f;
                a-=f;
                if(a==0) break;
            }
        }
        return flow;
    }
 
    int Max_Flow()
    {
        int flow=0;
        while(BFS())
        {
            memset(cur,0,sizeof(cur));
            flow += DFS(s,INF1);
        }
        return flow;
    }
}DC;
void floyd() {
    for(int k = 1;k <= f;k++) {
        for(int i = 1;i <= f;i++) {
            for(int j = 1;j <= f;j++) {
                if(d[i][k] < INF2 && d[k][j] < INF2) {
                    d[i][j] = min(d[i][j],d[i][k]+d[k][j]);
                    r = max(r,d[i][j]);
                }
            }
        }
    }
}
bool solve(ll limit) {
    DC.init(2*f+2,0,2*f+1);
    for(int i = 1;i <= f;i++) {
        DC.AddEdge(0,i,a[i]);
        DC.AddEdge(f+i,2*f+1,b[i]);
    }
    for(int i = 1;i <= f;i++) {
        for(int j = 1;j <= f;j++) {
            if(d[i][j] <= limit) DC.AddEdge(i,j+f,INF1);
        }
    }
    return DC.Max_Flow() == total;
}
int main() {
    scanf("%d%d",&f,&p);
    for(int i = 1;i <= f;i++) {
        scanf("%d%d",&a[i],&b[i]);
        total += a[i];
    } 
    for(int i = 1;i <= f;i++) {
        for(int j = 1;j <= f;j++) {
           d[i][j] = (i == j) ? 0 : INF2;
        }
    }
    for(int i = 0;i < p;i++) {
        int u,v;
        ll w;
        scanf("%d%d%I64d",&u,&v,&w);
        d[u][v] = d[v][u] = min(d[u][v],w);
    }
    r = 0;
    floyd();
    if(solve(r) == false) printf("-1\n");
    else {
        while(l < r) {
            mid = l + (r - l) / 2;
            if(solve(mid)) r = mid;
            else l = mid + 1;
        }
            printf("%I64d\n",r);
    }
    return 0;
}

Poj 2391 Ombrophobic Bovines 网络流 拆点

标签:else   create   join   cte   cap   答案   sum   str   must   

原文地址:https://www.cnblogs.com/pot-a-to/p/10989321.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!