码迷,mamicode.com
首页 > 其他好文 > 详细

Bone Collector

时间:2014-10-22 21:38:43      阅读:269      评论:0      收藏:0      [点我收藏+]

标签:blog   http   io   os   ar   for   sp   div   on   

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
bubuko.com,布布扣
 

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

 

Sample Output
14

bubuko.com,布布扣

 

#include<iostream>
using namespace std;
int p[1001][1001];
int max(int a,int b){
if(a>=b)
return a;
else
return b;
}

int main(){
int a[1000],v[1000];
int t,n,c;
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&c);
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
for(int i=1;i<=n;i++)
scanf("%d",&v[i]);
memset(p,0,sizeof(p));

for(int i=1;i<=n;i++)
for(int j=0;j<=c;j++){
if(j>=v[i])
p[i][j]=max(p[i-1][j],p[i-1][j-v[i]]+a[i]);
else
p[i][j]=p[i-1][j];
}

/* for(int i=0;i<n;i++)
for(int j=c;j>=v[i];j--){
p[j]=max(p[j],p[j-v[i]]+a[i]);
}
*/
printf("%d\n",p[n][c]);

}

return 0;
}

以上两种方法都可以接受,但注释的方法更高效

解释,可参考http://blog.sina.com.cn/s/blog_7e5541250100rtv5.html

 

Bone Collector

标签:blog   http   io   os   ar   for   sp   div   on   

原文地址:http://www.cnblogs.com/hoojjack/p/4044181.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!