码迷,mamicode.com
首页 > 其他好文 > 详细

poj2096--Collecting Bugs(概率dp第二弹)

时间:2014-10-22 22:07:09      阅读:238      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   for   

Collecting Bugs
Time Limit: 10000MS   Memory Limit: 64000K
Total Submissions: 2678   Accepted: 1302
Case Time Limit: 2000MS   Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It‘s important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan‘s opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan‘s work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan‘s working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

Source

Northeastern Europe 2004, Northern Subregion

给出s个子程序,n种bug,每天可以找出一个bug,该bug是随机的一种bug,在随机的一个程序里,问当找到n种bug,并且在每个程序中都找到过bug的期望。

dp[i][j],代表由已经在i个子程序中找到过j种bug到最后的期望,求得的dp[0][0]就是结果。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
double dp[1200][1200] ;
int main()
{
    int i , j , s , n ;
    scanf("%d %d", &s, &n);
    memset(dp,0,sizeof(dp));
    for(i = s ; i >= 0 ; i--)
    {
        for(j = n ; j >= 0 ; j--)
        {
            if( i == s && j == n ) continue ;
            else if( i == s )
                dp[i][j] = ( (n-j)*1.0/n*dp[i][j+1] + 1.0 ) * n / (n-j) ;
            else if( j == n )
                dp[i][j] = ( (s-i)*1.0/s*dp[i+1][j] + 1.0 ) * s / (s-i) ;
            else
                dp[i][j] = ( (s-i)*1.0*j/(s*n)*dp[i+1][j] + i*(n-j)*1.0/(s*n)*dp[i][j+1] + (s-i)*(n-j)*1.0/(s*n)*dp[i+1][j+1] + 1.0 )*s*n/(s*n-i*j);
        }
    }
    printf("%.4lf\n", dp[0][0]);
    return 0;
}


 

poj2096--Collecting Bugs(概率dp第二弹)

标签:des   style   blog   http   color   io   os   ar   for   

原文地址:http://blog.csdn.net/winddreams/article/details/40382267

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!