码迷,mamicode.com
首页 > 其他好文 > 详细

1013数素数

时间:2019-07-03 13:56:51      阅读:62      评论:0      收藏:0      [点我收藏+]

标签:UNC   article   sel   html   ensure   text   lang   htm   sdn   

令 P?i?? 表示第 i 个素数。现任给两个正整数 MN10?4??,请输出 P?M?? 到 P?N?? 的所有素数。

输入格式:

输入在一行中给出 M 和 N,其间以空格分隔。

输出格式:

输出从 P?M?? 到 P?N?? 的所有素数,每 10 个数字占 1 行,其间以空格分隔,但行末不得有多余空格。

输入样例:

5 27

输出样例:

11 13 17 19 23 29 31 37 41 43
47 53 59 61 67 71 73 79 83 89
97 101 103

  思路:我是用vector存素数,直到素数存够n个,就开始输出下标由m-1到n的质数,使用6x判断是否为质数。
https://blog.csdn.net/huang_miao_xin/article/details/51331710  链接为该种方法为何能判断质数的讲解。
代码如下:
#include <iostream>
#include <stdlib.h>
#include <cstring>
#include <math.h>
#include <vector>
#include <string.h>
using namespace std;
bool judge(int x)
{
    if (x == 2 || x == 3)return true;
    if (x % 6 != 1 && x % 6 != 5)return false;
    int tmp = sqrt(x);
    for (int i = 5; i <= tmp; i += 6)
    {
        if (x%i == 0 || x % (i + 2) == 0)return false;
    }
    return true;
}
int main()
{
    int m,n;
    scanf("%d %d",&m,&n);
    int num=2;
    vector<int> vec;
    while(vec.size()<n+1)
    {
        if(judge(num))vec.push_back(num);
        num++;
    }
    for(int i=m-1,j=0;i<n;i++,j++)
    {
        if(j%10==0&&i!=m-1)printf("\n");//换行
        if(i!=m-1&&(i-(m-1))%10!=0)printf(" ");//空格
        printf("%d",vec[i]);
    }
    return 0;
}

 

1013数素数

标签:UNC   article   sel   html   ensure   text   lang   htm   sdn   

原文地址:https://www.cnblogs.com/whocarethat/p/11125765.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!