码迷,mamicode.com
首页 > 其他好文 > 详细

划分树 [POJ 2104] K-th Number

时间:2014-10-23 16:06:46      阅读:236      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   for   

K-th Number
Time Limit: 20000MS   Memory Limit: 65536K
Total Submissions: 38225   Accepted: 12417
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

Source

Northeastern Europe 2004, Northern Subregion
 
划分树模板、、参考kuangbin大神的 = =
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
#define N 100010

int sorted[N];
int val[20][N];
int num[20][N];

void build(int l,int r,int d)
{
    if(l==r) return;
    int m=(l+r)>>1,same=0,i;
    
    for(i=l;i<=r;i++)
    {
        if(val[d][i]<sorted[m]) same++;
    }
    
    same=m-l+1-same;
    int lpos=l,rpos=m+1;
    
    for(i=l;i<=r;i++)
    {
        if(val[d][i]<sorted[m])
            val[d+1][lpos++]=val[d][i];
        else if(val[d][i]==sorted[m] && same>0)
        {
            val[d+1][lpos++]=val[d][i];
            same--;
        }
        else
            val[d+1][rpos++]=val[d][i];
        num[d][i]=num[d][l-1]+lpos-l;
    }
    build(l,m,d+1);
    build(m+1,r,d+1);
}
int query(int L,int R,int d,int l,int r,int k)
{
    if(l==r) 
        return val[d][l];
    int m=(L+R)>>1;
    
    int cnt=num[d][r]-num[d][l-1];
    if(cnt>=k)
    {
        int newl=L+num[d][l-1]-num[d][L-1];
        int newr=newl+cnt-1;
        return query(L,m,d+1,newl,newr,k);
    }
    else
    {
        int newr=r+num[d][R]-num[d][r];
        int newl=newr-(r-l-cnt);
        return query(m+1,R,d+1,newl,newr,k-cnt);
    }
}
int main()
{
    int m,n,i,j;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&sorted[i]); 
            val[0][i]=sorted[i];
        }
        sort(sorted+1,sorted+n+1); 
        build(1,n,0);
        while(m--)
        {
            int l,r,k;
            scanf("%d%d%d",&l,&r,&k);
            printf("%d\n",query(1,n,0,l,r,k));
        }
    }
}

 

划分树 [POJ 2104] K-th Number

标签:des   style   blog   http   color   io   os   ar   for   

原文地址:http://www.cnblogs.com/hate13/p/4045744.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!