码迷,mamicode.com
首页 > 其他好文 > 详细

poj3632

时间:2019-07-12 17:06:50      阅读:100      评论:0      收藏:0      [点我收藏+]

标签:specific   not   链接地址   HERE   opp   using   解题思路   ace   cat   

1.链接地址

https://vjudge.net/problem/POJ-3632

2.问题描述

 When shopping on Long Street, Michael usually parks his car at some random location, and then walks to the stores he needs. Can you help Michael choose a place to park which minimises the distance he needs to walk on his shopping round? Long Street is a straight line, where all positions are integer. You pay for parking in a specific slot, which is an integer position on Long Street. Michael does not want to pay for more than one parking though. He is very strong, and does not mind carrying all the bags around.

输入样例

2
4
24 13 89 37
6
7 30 41 14 39 42

输出样例

152
70

3.解题思路

排序找中间点即可。。。

4.算法实现源代码

#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
int num[20];
int main(){
    int n,cases;   
    cin>>n;    
    for(int i=0;i<n;i++){
        cin>>cases;
        for(int j=0;j<cases;j++){
            cin>>num[j];
        }
        sort(num,num+cases); 
        cout<<2*(num[cases-1]-num[0])<<endl;
    }
    return 0;
}

 

poj3632

标签:specific   not   链接地址   HERE   opp   using   解题思路   ace   cat   

原文地址:https://www.cnblogs.com/KasenBob/p/11177026.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!