码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1198

时间:2014-10-23 22:17:35      阅读:140      评论:0      收藏:0      [点我收藏+]

标签:des   blog   http   io   os   ar   java   for   strong   

Farm Irrigation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5989    Accepted Submission(s): 2589


Problem Description
Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.

bubuko.com,布布扣

Figure 1


Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map 

ADC
FJK
IHE

then the water pipes are distributed like 

bubuko.com,布布扣

Figure 2


Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. 

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? 

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.
 

 

Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of ‘A‘ to ‘K‘, denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.
 

 

Output
For each test case, output in one line the least number of wellsprings needed.
 

 

Sample Input
2 2 DK HF 3 3 ADC FJK IHE -1 -1
 

 

Sample Output
2 3
 
我的并查集,写的真是失败= =。
 
#include <cstdio>
#include <cstring>
#include <queue>
#include <set>
#include <cmath>
using namespace std;
const int N=55;
int n,m;
int f[N*N];
char maze[N][N];
int t[12][4] ={{1,1,0,0},{0,1,1,0},{1,0,0,1},{0,0,1,1},
                 {0,1,0,1},{1,0,1,0},{1,1,1,0},{1,1,0,1},
                 {1,0,1,1},{0,1,1,1},{1,1,1,1},{0,0,0,0}};
int find(int x)
{
    if(f[x] == x) return x;
    else return f[x] = find(f[x]);
}
set<int> st;
void init()
{
    for(int i = 1; i <= n*m; i++)
        f[i] = i;
    memset(maze, ‘A‘+11, sizeof(maze));
    st.clear();
}
int fun(int i, int j)
{
    return (i-1)*m + j;
}
void Union(int x, int y)
{
    x = find(x);
    y = find(y);
    if(x != y) f[x] = y;
}
void judge(int i, int j)
{
    char now = maze[i][j];
    char up = maze[i-1][j];
    char left = maze[i][j-1];
    if(t[now-‘A‘][1] == 1 && t[up-‘A‘][3] == 1) {
                    int a = fun(i,j);
                    int b = fun(i-1,j);
                    Union(a,b);
                }
    if(t[now-‘A‘][0] == 1 && t[left-‘A‘][2] == 1) {
                    int a = fun(i,j);
                    int b = fun(i,j-1);
                    Union(a,b);
                }
}
int main(){
    while(scanf("%d %d", &n, &m)){
        if(n == -1 && m == -1) break;
        init();
        for(int i = 1; i <= n; i++)
            scanf("%s", maze[i]+1);
        for(int i = 1; i <= n; i++)
        for(int j = 1; j <= m; j++){
            judge(i,j);

        }
        for(int i = 1; i <= n*m; i++)
            st.insert(find(i));
        printf("%d\n", st.size());

    }
    return 0;
}

  

HDU 1198

标签:des   blog   http   io   os   ar   java   for   strong   

原文地址:http://www.cnblogs.com/brokesb/p/4046915.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!