码迷,mamicode.com
首页 > 其他好文 > 详细

Rails

时间:2019-07-20 00:14:46      阅读:120      评论:0      收藏:0      [点我收藏+]

标签:describes   dib   tab   until   rip   clu   direct   idt   eof   

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.
技术图片

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

Input
The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0.

The last block consists of just one line containing 0.
Output
The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null‘‘ block of the input.
Sample Input
5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0
Sample Output
Yes
No

Yes

题目大意 以1 2 3 。。。 n的方式进栈判断是否能按照他的形式出栈
入栈时,边入边判断,判断是否满足出栈条件
最后如果 所有元素都出栈即n=pos或者栈为空则满足为yes

类似题目:
https://www.cnblogs.com/Accepting/p/11216112.html
#include<iostream>
#include<cstdio>
#include<stack>
using namespace std;
int a[1010];
int main()
{
    int n;
    while(cin>>n,n){
        while(scanf("%d",&a[0])!=EOF && a[0])
        {
            stack<int >s;
            for(int i=1;i<n;i++)
                scanf("%d",&a[i]);
            int pos=0;
            for(int i=1;i<=n;i++){
                s.push(i);
                while(s.size()&&s.top()==a[pos])
                {
                    s.pop();
                    pos++;
                }    
            }
            if(pos==n) printf("Yes\n");
            else printf("No\n");
        }
        printf("\n");
    }
    return 0;
 } 

 



Rails

标签:describes   dib   tab   until   rip   clu   direct   idt   eof   

原文地址:https://www.cnblogs.com/Accepting/p/11216121.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!