码迷,mamicode.com
首页 > 其他好文 > 详细

SDNU 1536.How many users on SDNU OJ(水题)

时间:2019-07-20 17:24:44      阅读:122      评论:0      收藏:0      [点我收藏+]

标签:bsp   got   define   line   put   tput   exp   --   desc   

Description

There are many users on SDNU OJ, but only the one who registered can use it. We think different username represent different user.

One day ZhouXiaohui got a record of "Status Pages", the captain Albert_s wants to know how many users are using SDNU OJ at that time.

He will give you an "Accepted" as a gift if you help him figure out this problem.

技术图片

Input

The first line of the input contains an integer T, denoting the number of "Status Pages" ZhouXiaohui got.
In each "Status Pages", there is a single integers n in one line, denoting all the username on this pages, then following username .
, , ?

Output

For each testcase, print a single line starting with "Case #i:"(i indicates the case number) and then a single integer, denoting the answer Albert_s wants to know, separated with a single space.

Sample Input

1
3
ZhouXiaohui
ZhouLaohui
ZhouXiaohui

Sample Output

Case #1: 2

Source

Unknown
#include <cstdio>
#include <iostream>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <vector>
#include <map>
using namespace std;
#define ll long long

int t, n, sum;
string name[100000+8];

int main()
{
    scanf("%d", &t);
    int miao = t;
    while(t--)
    {
        bool flag = 0;
        int num = 0;
        cin>>n;
        for(int i = 0; i<n; i++)
        {
            flag = 0;
            cin>>name[i];
            for(int j = 0; j<i; j++)
            {
                if(name[i] == name[j])
                {
                    flag = 1;
                    break;
                }
            }
            if(flag)continue;
            else num++;
        }
        printf("Case #%d: %d\n", miao-t, num);
    }
    return 0;
}

 

SDNU 1536.How many users on SDNU OJ(水题)

标签:bsp   got   define   line   put   tput   exp   --   desc   

原文地址:https://www.cnblogs.com/RootVount/p/11218141.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!