码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 147 Dollars (DP)

时间:2014-10-23 22:49:46      阅读:247      评论:0      收藏:0      [点我收藏+]

标签:style   http   color   io   os   ar   for   sp   on   

New Zealand currency consists of $100, $50, $20, $10, and $5 notes and $2, $1, 50c, 20c, 10c and 5c coins. Write a program that will determine, for any given amount, in how many ways that amount may be made up. Changing the order of listing does not increase the count. Thus 20c may be made up in 4 ways: 1 bubuko.com,布布扣 20c, 2 bubuko.com,布布扣 10c, 10c+2 bubuko.com,布布扣 5c, and 4 bubuko.com,布布扣 5c.

Input

Input will consist of a series of real numbers no greater than $300.00 each on a separate line. Each amount will be valid, that is will be a multiple of 5c. The file will be terminated by a line containing zero (0.00).

Output

Output will consist of a line for each of the amounts in the input, each line consisting of the amount of money (with two decimal places and right justified in a field of width 6), followed by the number of ways in which that amount may be made up, right justified in a field of width 17.

Sample input

0.20
2.00
0.00

Sample output

  0.20                4

2.00 293

题意:经典问题,换钱。

精度呀马丹。打表速度可能快点。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
typedef unsigned long long LL;
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
int a[]={5,10,20,50,100,200,500,1000,2000,5000,10000};
LL dp[300100];
int n;
int main()
{
    double x;
    while(~scanf("%lf",&x)&&x!=0)
    {
        n=(int)(x*100+0.5);//+0.5注意精度
//        cout<<"23333   "<<n<<endl;
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        REP(i,11)//对于每一种货币考虑加入到j中
        {
            REPF(j,a[i],n)
               dp[j]+=dp[j-a[i]];
        }
        printf("%6.2f%17lld\n",x,dp[n]);
    }
}


UVA 147 Dollars (DP)

标签:style   http   color   io   os   ar   for   sp   on   

原文地址:http://blog.csdn.net/u013582254/article/details/40403873

(0)
(1)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!