码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2828 Buy Tickets(线段树)

时间:2014-10-23 22:49:24      阅读:299      评论:0      收藏:0      [点我收藏+]

标签:线段树   poj   iostream   

Language:
Buy Tickets
Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 13847   Accepted: 6926

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i ? 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

bubuko.com,布布扣

Source



买票插队,从后往前,以为后面的肯定就是确定的


//排队,输入n,然后n行 a b  表示b插在a的位置,最后输出最终队伍的编号
//对于这个题有一个问题需要注意,就是插入位置为0需要加1,也就是把所有的位置加1

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)
using namespace std;
#define N 200005

int ans[N],a[N],va[N];

struct stud{
int le,ri;
int len;
}f[N*4];

int n;

void build(int pos,int le,int ri)
{
    f[pos].le=le;
    f[pos].ri=ri;
    f[pos].len=ri-le+1;
    if(le==ri) return ;

    int mid=MID(le,ri);

    build(L(pos),le,mid);
    build(R(pos),mid+1,ri);
}

void update(int pos,int le,int va)
{
    f[pos].len--;
    if(f[pos].le==f[pos].ri)
    {
        ans[f[pos].le]=va;
        return ;
    }

    if(f[L(pos)].len>=le)
        update(L(pos),le,va);
    else
        update(R(pos),le-f[L(pos)].len,va);
}

int main()
{
    int i;
    while(~scanf("%d",&n))
    {
        build(1,1,n);

        for(i=1;i<=n;i++)
           scanf("%d%d",&a[i],&va[i]);

        for(i=n;i>=1;i--)
            update(1,a[i]+1,va[i]);

        for(i=1;i<=n;i++)
          if(i==1)
             printf("%d",ans[i]);
        else
            printf(" %d",ans[i]);
        printf("\n");
    }
    return 0;
}




POJ 2828 Buy Tickets(线段树)

标签:线段树   poj   iostream   

原文地址:http://blog.csdn.net/u014737310/article/details/40403543

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!