码迷,mamicode.com
首页 > 其他好文 > 详细

Checking an Alibi-Floyd

时间:2019-07-23 16:58:45      阅读:132      评论:0      收藏:0      [点我收藏+]

标签:turn   Requires   second   pass   scanf   pac   field   switch   rmi   

A crime has been comitted: a load of grain has been taken from the barn by one of FJ‘s cows. FJ is trying to determine which of his C (1 <= C <= 100) cows is the culprit. Fortunately, a passing satellite took an image of his farm M (1 <= M <= 70000) seconds before the crime took place, giving the location of all of the cows. He wants to know which cows had time to get to the barn to steal the grain. 

Farmer John‘s farm comprises F (1 <= F <= 500) fields numbered 1..F and connected by P (1 <= P <= 1,000) bidirectional paths whose traversal time is in the range 1..70000 seconds (cows walk very slowly). Field 1 contains the barn. It takes no time to travel within a field (switch paths). 

Given the layout of Farmer John‘s farm and the location of each cow when the satellite flew over, determine set of cows who could be guilty. 

NOTE: Do not declare a variable named exactly ‘time‘. This will reference the system call and never give you the results you really want.

Input

* Line 1: Four space-separated integers: F, P, C, and M 

* Lines 2..P+1: Three space-separated integers describing a path: F1,F2, and T. The path connects F1 and F2 and requires T seconds to traverse. 

* Lines P+2..P+C+1: One integer per line, the location of a cow. The first line gives the field number of cow 1, the second of cow 2, etc.

Output

* Line 1: A single integer N, the number of cows that could be guilty of the crime. 

* Lines 2..N+1: A single cow number on each line that is one of the cows that could be guilty of the crime. The list must be in ascending order.

Sample Input

7 6 5 8
1 4 2
1 2 1
2 3 6
3 5 5
5 4 6
1 7 9
1
4
5
3
7

Sample Output

4
1
2
3
4

Hint

INPUT DETAILS: 

Fields/distances like this: 
          6

4------5
| |
2| |
| |
7-----1 |5
9 | |
1| |
| |
2------3

OUTPUT DETAILS: 

Any cow except cow 5 could have done it. Cow 5 would take 9 seconds to get to the barn.

题意:农场有 F 个点,已知 P条边以及每条边的起点终点和通过时间,给出 C 个有牛的点,求在规定时间M内能从起点到达牛当前位置的牛的数量,并按升序输出牛的编号。

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=1005;
const int INF=1e5+10;
int d[maxn][maxn];
int F,M,P,C;
void floyd()//求最短路的模板
{
    for(int k=1;k<=F;k++)
        for(int i=1;i<=F;i++)
            for(int j=1;j<=F;j++)
                if(d[i][k]!=INF&&d[k][j]!=INF)
                    d[i][j]=min(d[i][j],d[i][k]+d[k][j]);
}
int main()
{
    while(~scanf("%d%d%d%d",&F,&P,&C,&M))
    {
        for(int i=1;i<=F;i++)
        {
            for(int j=i+1;j<=F;j++)
            {
                d[i][j]=d[j][i]=INF;
            }
        }
        for(int i=1;i<=F;i++)
            d[i][i]=0;
        for(int i=0;i<P;i++)
        {
            int from,to,cost;
            scanf("%d%d%d",&from,&to,&cost);
            if(d[from][to]>cost)
            {
                d[from][to]=cost;
                d[to][from]=cost;
            }
        }
        int s[maxn],t[maxn];
        for(int i=1;i<=C;i++)//编号为i的牛的位置
            scanf("%d",&t[i]);
        floyd();
        int ans=0,cnt=0,res[maxn];//res用于记录结果中牛的编号
        for(int i=1;i<=C;i++){
            if(d[1][t[i]]<=M){//如果从起点到牛的位置<=M,说明此牛是偷吃了粮食
                res[cnt++]=i;
                ans++;
            }
        }
        printf("%d\n",ans);
        for(int i=0;i<cnt;i++)
            printf("%d\n",res[i]);
    }
    return 0;
}

 

Checking an Alibi-Floyd

标签:turn   Requires   second   pass   scanf   pac   field   switch   rmi   

原文地址:https://www.cnblogs.com/LJHAHA/p/11232563.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!