码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1318 Word Amalgamation

时间:2019-07-24 22:50:55      阅读:191      评论:0      收藏:0      [点我收藏+]

标签:and   mos   obj   apt   xxxx   text   asterisk   href   cout   

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9968   Accepted: 4774

Description

In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.

Input

The input contains four parts: 1) a dictionary, which consists of at least one and at most 100 words, one per line; 2) a line containing XXXXXX, which signals the end of the dictionary; 3) one or more scrambled ‘words‘ that you must unscramble, each on a line by itself; and 4) another line containing XXXXXX, which signals the end of the file. All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X‘s.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.

Output

For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line "NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.

Sample Input

tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX

Sample Output

score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******

题意:用XXXXXX表示文本输入部分结束和查询部分结束;如果如果查询的一个单词和输入的单词字母组成一样;输出文本部分所用符合的单词;每查询一次输出*******分隔

题解:一个单词不管怎么排列,经过排序之后的形式一定是一样的,用排序之后的单词作为键值,用map匹配

#include<iostream>
#include<algorithm>
#include<string.h>
#include<string>
#include<math.h>
#include<map>
#include<set>
#define ll long long
using namespace std;
map<string,string>m;
string s,ss;
int n;
int main()
{
    int flag=0;
    while(flag!=2)
    {
        cin>>s;
        if(s[0]==X)
        {
            flag++;
            continue;
        }
        if(flag==0)
        {
        ss=s;
           sort(ss.begin(),ss.end());
            m[s]=ss;
                
        }
        if(flag==1)
        {
            int flag2=0;
            sort(s.begin(),s.end());
            map<string,string>::iterator it;
            for(it=m.begin();it!=m.end();it++)
            {
                if(it->second==s)
                {
                    flag2=1;
                    cout<<it->first<<endl;
                }
            }
            if(flag2==0)
                cout<<"NOT A VALID WORD"<<endl;
            cout<<"******"<<endl;
        }
    }

    return 0;

}

 

poj 1318 Word Amalgamation

标签:and   mos   obj   apt   xxxx   text   asterisk   href   cout   

原文地址:https://www.cnblogs.com/-citywall123/p/11241127.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!