码迷,mamicode.com
首页 > 其他好文 > 详细

SDNU 1377.Problem C: Jolly Jumpers(水题)

时间:2019-07-27 19:53:40      阅读:111      评论:0      收藏:0      [点我收藏+]

标签:using   lse   mod   source   icpc   can   color   const   arch   

Description

 

Problem C: Jolly Jumpers

A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance,

 

1 4 2 3

is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.

 

Input

Each line of input contains an integer n < 3000 followed by n integers representing the sequence. 

Output

For each line of input, generate a line of output saying "Jolly" or "Not jolly".

Sample Input

4 1 4 2 3
5 1 4 2 -1 6

Sample Output

Jolly
Not jolly

Source

题意:n个数字,每对连续的两个数字,如果后数与前数差值的绝对值能覆盖1~(n-1)的每一个数,就输出Jolly,否则输出Not jolly
#include <cstdio>
#include <iostream>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <map>
using namespace std;
#define ll long long
const int inf = 0x3f3f3f3f;
const int mod = 1e9+7;

int n, a[10000+8], buffer[10000+8];

int main()
{
    while(~scanf("%d", &n))
    {
        int id = 0;
        for(int i = 0; i<n; i++)
        {
            scanf("%d", &a[i]);
            if(i)buffer[id++] = abs(a[i]-a[i-1]);
        }
        sort(buffer, buffer+id);
        bool flag = 1;
        for(int i = 0; i<id; i++)
        {
            if(buffer[i] != i+1)
            {
                flag = 0;
                break;
            }
        }
        if(flag)printf("Jolly\n");
        else printf("Not jolly\n");
    }
    return 0;
}

 

SDNU 1377.Problem C: Jolly Jumpers(水题)

标签:using   lse   mod   source   icpc   can   color   const   arch   

原文地址:https://www.cnblogs.com/RootVount/p/11256416.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!