码迷,mamicode.com
首页 > 其他好文 > 详细

Monkey and Banana HDU - 1069 (基础dp)

时间:2019-07-30 16:02:03      阅读:98      评论:0      收藏:0      [点我收藏+]

标签:ems   blocks   sea   test   group   determine   height   pes   open   

Monkey and Banana

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food. 

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn‘t be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks. 

InputThe input file will contain one or more test cases. The first line of each test case contains an integer n, 
representing the number of different blocks in the following data set. The maximum value for n is 30. 
Each of the next n lines contains three integers representing the values xi, yi and zi. 
Input is terminated by a value of zero (0) for n. 
OutputFor each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height". 
Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题意:有 n 种砖,每一种都无限多,分别有长宽高,可以任意摆放。现在要把这些砖叠起来,如果 A 放在 B 上,要求 A 的长宽比 B 的长宽都要小。问最多能叠多高。。。
思路:由于每种砖有无限多,直接枚举一块砖所有可能摆放方式的长宽高,然后按照长,宽排序 ... 然后就类似LIS的问题 ...
技术图片
#include<bits/stdc++.h>
#define debug(x) cout << "[" << #x <<": " << (x) <<"]"<< endl
#define pii pair<int,int>
#define clr(a,b) memset((a),b,sizeof(a))
#define rep(i,a,b) for(int i = a;i < b;i ++)
#define pb push_back
#define MP make_pair
#define LL long long
#define ull unsigned LL
#define ls i << 1
#define rs (i << 1) + 1
#define INT(t) int t; scanf("%d",&t)

using namespace std;

struct xx{
    int c,k,g;
    xx(int c = 0,int k = 0,int g = 0):
        c(c),k(k),g(g){}
}zhuan[185];
int dp[185];

bool cmp(xx A,xx B){
    if(A.c != B.c) return A.c < B.c;
    return A.k < B.k;
}

int main() {
    int n;
    int cas = 0;
    while(~scanf("%d",&n) && n){
        int cnt = 0;
        for(int i = 1;i <= n;++ i){
            int l,r,k; scanf("%d%d%d",&l,&r,&k);
            zhuan[++ cnt] = xx(l,r,k);
            zhuan[++ cnt] = xx(l,k,r);
            zhuan[++ cnt] = xx(r,l,k);
            zhuan[++ cnt] = xx(r,k,l);
            zhuan[++ cnt] = xx(k,l,r);
            zhuan[++ cnt] = xx(k,r,l);
        }
        sort(zhuan + 1,zhuan + cnt + 1,cmp);
        rep(i,1,cnt + 1) dp[i] = zhuan[i].g;
        for(int i = 1;i <= cnt;++ i){
            for(int j = i + 1;j <= cnt;++ j)
                if(zhuan[i].c < zhuan[j].c && zhuan[i].k < zhuan[j].k)
                    dp[j] = max(dp[j],dp[i] + zhuan[j].g);
        }
        int maxx = 0;
        for(int i = 1;i <= cnt;++ i)
            maxx = max(maxx,dp[i]);
        cout << "Case " << ++ cas << ": maximum height = " << maxx << endl;
//        cout << maxx << endl;
    }
    return 0;
}
View Code

 

 

Monkey and Banana HDU - 1069 (基础dp)

标签:ems   blocks   sea   test   group   determine   height   pes   open   

原文地址:https://www.cnblogs.com/rookie-acmer/p/11270193.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!