码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 区间DP Multiplication Puzzle

时间:2019-07-31 16:39:23      阅读:106      评论:0      收藏:0      [点我收藏+]

标签:ace   example   name   contains   std   mini   minimal   amp   def   

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650




思路: 区间DP
则f[i][j] 表示i+1 到 j-1 已经被用掉
f[i][j]=min(f[i][j],f[i][k]+f[i][k]+a[i]*a[k]*a[j]);


code:
//
#include<iostream>
#include<cstdio>
#define maxnn 300 
int f[maxnn][maxnn];
int n;
int a[maxnn];
using namespace std;
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    scanf("%d",&a[i]);
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
            f[i][j]=1e9;
    for(int i=1;i<n;i++)
    f[i][i+1]=0;
    for(int i=n-1;i>=1;i--)
        for(int j=i+1;j<=n;j++)
            {
                for(int k=i+1;k<j;k++)
                    f[i][j]=min(f[i][j],f[i][k]+f[k][j]+a[k]*a[i]*a[j]);
                    
             } 
    cout<<f[1][n];
    
 } 

 

POJ 区间DP Multiplication Puzzle

标签:ace   example   name   contains   std   mini   minimal   amp   def   

原文地址:https://www.cnblogs.com/OIEREDSION/p/11277230.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!