码迷,mamicode.com
首页 > 其他好文 > 详细

1008 Elevator (20 分)

时间:2019-08-03 11:19:56      阅读:104      评论:0      收藏:0      [点我收藏+]

标签:contains   otto   order   line   names   ext   ast   ade   cond   

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41


#include<iostream>

using namespace std;

int main(){
    int N;
    cin>>N;
    int sum=0;
    int st=0,last;
    while(N--){
        cin>>last;
        if(last>st)sum+=(last-st)*6;
        if(last<st)sum+=(st-last)*4;
        st=last;
        sum+=5;
    }
    cout<<sum;
}

 

1008 Elevator (20 分)

标签:contains   otto   order   line   names   ext   ast   ade   cond   

原文地址:https://www.cnblogs.com/TBhacker/p/11293731.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!