码迷,mamicode.com
首页 > 其他好文 > 详细

kmp(前缀出现次数next应用)

时间:2019-08-03 21:39:43      阅读:127      评论:0      收藏:0      [点我收藏+]

标签:line   math   ice   cat   forever   comm   包括   scan   return   

http://acm.hdu.edu.cn/showproblem.php?pid=3336

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17068    Accepted Submission(s): 7721


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

 

Sample Input
1 4 abab
 

 

Sample Output
6
 

 

Author
foreverlin@HNU
 

 

Source
 

 

Recommend
lcy
题意:求字符串所有前缀出现的次数(包括本身)
思路:求所有next的值的个数加上前缀本身
 
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <algorithm>
#include <iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include <stdio.h>
#include <string.h>
using namespace std;
char a[200009];

int num;


void getnext(char* a, int len , int *next)
{
    next[0] = -1 ;
    int k = -1 , j = 0 ;
    while(j < len)
    {
        if(k == -1 || a[j] == a[k])
        {
            k++;
            j++;
        //    if(a[j] != a[k])
                next[j] = k ;
          //  else
          //  {
          //      next[j] = next[k];
           // }

        }
        else
        {
            k = next[k];
        }
    }
}

int main()
{int n ;
    scanf("%d" , &n);
    while(n--)
    {
        int next[200009];
        int l ;
        scanf("%d" , &l);
        scanf("%s" , a);
        getnext(a , l , next);
        int j = 0 ;
        for(int i = 0 ; i <= l ; i++)
        {
        //    cout << next[i] << " " ;
            j = i ;
            while(next[j] > 0)
            {
                num = (num + 1) % 10007 ;
                j = next[j];
            }
        }
       // cout << endl ;

        printf("%d\n" , (num + l)%10007);
        num = 0 ;
    }

    return 0 ;
}

 

kmp(前缀出现次数next应用)

标签:line   math   ice   cat   forever   comm   包括   scan   return   

原文地址:https://www.cnblogs.com/nonames/p/11296242.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!