码迷,mamicode.com
首页 > 其他好文 > 详细

C - Ekka Dokka

时间:2019-08-12 23:43:21      阅读:96      评论:0      收藏:0      [点我收藏+]

标签:while   gets   ash   after   and   actor   tip   contain   ber   

Ekka and his friend Dokka decided to buy a cake. They both love cakes and that‘s why they want to share the cake after buying it. As the name suggested that Ekka is very fond of odd numbers and Dokka is very fond of even numbers, they want to divide the cake such that Ekka gets a share of Nsquare centimeters and Dokka gets a share of M square centimeters where N is odd and M is even. Both N and M are positive integers.

They want to divide the cake such that N * M = W, where W is the dashing factor set by them. Now you know their dashing factor, you have to find whether they can buy the desired cake or not.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer W (2 ≤ W < 263). And W will not be a power of 2.

Output

For each case, print the case number first. After that print "Impossible" if they can‘t buy their desired cake. If they can buy such a cake, you have to print N and M. If there are multiple solutions, then print the result where M is as small as possible.

Sample Input

3

10

5

12

Sample Output

Case 1: 5 2

Case 2: Impossible

Case 3: 3 4

题目大意:就是判断一个数是否可以分解为一个奇数和一个偶数的乘积,并且使偶数最小

题解  先判断如果是奇数的话,直接输出impossible ,因为他不可能存在偶数因子,对于偶数,首先2是一个因子,然后循环除以2直到原数字变成了奇数就可以了

#include<iostream>
#include<cstdio>
#include<map>
#include<vector>
using namespace std;
typedef long long ll;
int main(){
    int t;
    scanf("%d",&t);
    for(int i=1;i<=t;i++){
        ll x;
        scanf("%lld",&x);
        
        if(x&1) {
            printf("Case %d: Impossible\n",i);
        }
        
        else {
            ll ans=1,t=1;
            while(x%2==0){
                x=x/2;
                ans*=2;
            }
            printf("Case %d: %lld %lld\n",i,x,ans);
        }
    }
    return 0;
}

 

C - Ekka Dokka

标签:while   gets   ash   after   and   actor   tip   contain   ber   

原文地址:https://www.cnblogs.com/Accepting/p/11343247.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!