码迷,mamicode.com
首页 > 其他好文 > 详细

PATA1028 List Sorting

时间:2019-08-13 00:16:53      阅读:72      评论:0      收藏:0      [点我收藏+]

标签:more   pause   sample   warning   判断   func   using   and   strcmp   

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:
Each input file contains one test case. For each case, the first line contains two integers N (≤10
?5
?? ) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student‘s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:
For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID‘s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID‘s in increasing order.

Sample Input 1:
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1:
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2:
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2:
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3:
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3:
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

开始技术总结:

  • 主要就是cmp函数的编写,可以通过编写三个cmp函数来分别对应于三种排序的情况,然后根据输入得到的C值来选择哪个cmp函数应用,我使用的是通过定义一个全局变量C,然后编写一个cmp函数,在cmp函数里面区别三种排序情况。注意如果要使用C来判断,必须把C定义为全局变量。这个函数的参考代码如下:
bool cmp(Student a, Student b) {
    if (C == 1) {
        return a.id < b.id;
    }
    else if (C == 2) {
        if (strcmp(a.name, b.name) == 0) {
            return a.id < b.id;
        }
        else {
            return strcmp(a.name, b.name) < 0;
        }
        
    }
    else if (C == 3) {
        if (a.grade == b.grade) {
            return a.id < b.id;
        }
        else {
            return a.grade < b.grade;
        }
    }
}

所有部分的代码:

//在VS2017上编写,通过PAT测试满分25
#define _CRT_SECURE_NO_WARNINGS
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
using namespace std;

struct Student {
    int id;
    char name[10];
    int grade;
}stu[100010];

int C;//全局变量用来在cmp函数使用,判定排序方式

bool cmp(Student a, Student b) {
    if (C == 1) {
        return a.id < b.id;
    }
    else if (C == 2) {
        if (strcmp(a.name, b.name) == 0) {
            return a.id < b.id;
        }
        else {
            return strcmp(a.name, b.name) < 0;
        }
        
    }
    else if (C == 3) {
        if (a.grade == b.grade) {
            return a.id < b.id;
        }
        else {
            return a.grade < b.grade;
        }
    }
}
int main() {
    int N;//分别记录人数N
    scanf("%d%d", &N, &C);
    for (int i = 0; i < N; i++) {
        scanf("%d%s%d", &stu[i].id, stu[i].name, &stu[i].grade);
    }
    sort(stu, stu + N, cmp);
    for (int i = 0; i < N; i++) {
        printf("%06d %s %d\n", stu[i].id, stu[i].name, stu[i].grade);
    }

    system("pause");
    return 0;
}

PATA1028 List Sorting

标签:more   pause   sample   warning   判断   func   using   and   strcmp   

原文地址:https://www.cnblogs.com/tsruixi/p/11337246.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!