码迷,mamicode.com
首页 > 其他好文 > 详细

LIS模板题(Longest Ordered Subsequence)

时间:2019-08-13 11:52:37      阅读:96      评论:0      收藏:0      [点我收藏+]

标签:cout   sub   ges   sequence   ems   一个   sizeof   size   enc   

LIS模板题(Longest Ordered Subsequence)

poj-2533

给出一个序列,求出这个序列的最长上升子序列。

序列A的上升子序列B定义如下:

B为A的子序列
B为严格递增序列
Input
第一行包含一个整数n,表示给出序列的元素个数。

第二行包含n个整数,代表这个序列。
1 <= N <= 1000
Output
输出给出序列的最长子序列的长度。

Sample Input
7
1 7 3 5 9 4 8
Sample Output
4


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <iostream>
using namespace std;
#define N 1001
int a[N];
int l[N];
int main()
{
    int i, n, j, max = 0;
    cin >> n;
    for (i = 0; i < n; i++)
        cin >> a[i];
    memset(l, 0, sizeof(l));

    l[0] = 1;
    for (i = 1; i < n; i++)
    {
        l[i] = 1;
        for (j = 0; j < i; j++)
            if (a[j] < a[i] && l[j] >= l[i])
                l[i] = l[j] + 1;
    }
    //这里注意下,在求的时候l[i]的意思是:以a[i]结尾的最长上升子序列。
    //但是,整个串的最长公共子序列可能不是以a[i]结尾。所以要遍历结尾,取最大值
    for (i = 0; i < n; i++)
        if (l[i] > max)
            max = l[i];
    cout << max << endl;
    return 0;
}

LIS模板题(Longest Ordered Subsequence)

标签:cout   sub   ges   sequence   ems   一个   sizeof   size   enc   

原文地址:https://www.cnblogs.com/tttfu/p/11344915.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!