码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 4704 Sum 规律 欧拉定理

时间:2014-10-24 20:50:09      阅读:194      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   java   


规律 欧拉定理:

找规律 2^n-1 ,n 很大用欧拉定理

Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1465    Accepted Submission(s): 622


Problem Description
bubuko.com,布布扣
 

Sample Input
2
 

Sample Output
2
Hint
1. For N = 2, S(1) = S(2) = 1. 2. The input file consists of multiple test cases.
 

Source
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

typedef long long int LL;

const LL mod=1e9+7;
const LL phi=1e9+6;

char str[200000];

LL quickpow(LL x)
{
  if(x==0LL) return 1LL;
  LL e=2,ret=1;
  while(x)
    {
      if(x%2)
        ret=(ret*e)%mod;
      e=(e*e)%mod;
      x/=2LL;
    }
  return ret;
}

int main()
{
  while(scanf("%s",str)!=EOF)
    {
      int len=strlen(str);
      /// N - 1
      if(str[len-1]>'0')
        {
          str[len-1]--;
        }
      else
        {
          int p=len-1;
          while(str[p]=='0')
            {
              str[p]='9';
              p--;
            }
          str[p]--;
        }
      LL ret=0;
      for(int i=0;i<len;i++)
        {
          ret=ret*10LL+str[i]-'0';
          while(ret>=phi)
            ret-=phi;
        }
      cout<<quickpow(ret)<<endl;
    }
  return 0;
}


HDOJ 4704 Sum 规律 欧拉定理

标签:des   style   blog   http   color   io   os   ar   java   

原文地址:http://blog.csdn.net/ck_boss/article/details/40432443

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!