码迷,mamicode.com
首页 > 其他好文 > 详细

PAT Advanced 1041 Be Unique (20 分)

时间:2019-08-15 06:06:29      阅读:82      评论:0      收藏:0      [点我收藏+]

标签:positive   put   false   advance   with   test   system   none   lang   

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

 

#include <iostream>
using namespace std;
int main(){
    int T;
    cin>>T;
    int va[T],coun[10001];
    for(int i=0;i<T;i++){
        scanf("%d",&va[i]);
        coun[va[i]]++;
    }
    bool has=false;
    for(int i=0;i<T;i++){
        if(coun[va[i]]==1) {
            cout<<va[i];
            has=true;
            break;
        }
    }
    if(!has) cout<<"None";
    system("pause");
    return 0;
}

 

PAT Advanced 1041 Be Unique (20 分)

标签:positive   put   false   advance   with   test   system   none   lang   

原文地址:https://www.cnblogs.com/littlepage/p/11355648.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!