码迷,mamicode.com
首页 > 其他好文 > 详细

PAT Advanced 1050 String Subtraction (20 分)

时间:2019-08-15 06:12:53      阅读:70      评论:0      收藏:0      [点我收藏+]

标签:one   ica   fas   turn   new   set   The   iostream   etl   

Given two strings S?1?? and S?2??, S=S?1??S?2?? is defined to be the remaining string after taking all the characters in S?2?? from S?1??. Your task is simply to calculate S?1??S?2?? for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S?1?? and S?2??, respectively. The string lengths of both strings are no more than 1. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S?1??S?2?? in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.


#include <iostream>
using namespace std;

int main(){
    string s1,s2,res="";
    getline(cin,s1);
    getline(cin,s2);
    for(int i=0;i<s1.length();i++){
        if(s2.find(s1[i])==s2.npos) res+=s1[i];
    }
    cout<<res;
    system("pause");
    return 0;
}

 

 

PAT Advanced 1050 String Subtraction (20 分)

标签:one   ica   fas   turn   new   set   The   iostream   etl   

原文地址:https://www.cnblogs.com/littlepage/p/11355652.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!